Zwift Crashing on Launch: MacBook Pro M1 Pro: Monterey 12.0.1

Hey I am copying from another thread just in case it needs to be here:

Hi there, after having issues myself on an m1 Pro Macbook Pro I looked into the error message being produced. My symptoms where intimidate crash after trying to launch the app. There were no /Application Support/Zwift files to remove as this was after a fresh install. I tried manually launching the app from the terminal with rossetta to no avail either.

The fix (or workaround) I discovered after reading through the crash report was to remove the app signature, as the error message was “attachment of code signature supplement failed: 1 apple m1”. To remove the signature from the Zwift app, run this in your terminal: sudo codesign --remove-signature /Applications/Zwift.app . It will ask you for your password, enter it, and hit enter.

This fixed it in my case, be cautious though and don’t start removing signatures from other apps you have downloaded as signatures are meant to prove the app came from a certain developer. It is safe in this case as we all know where we downloaded Zwift and who they are.

Hope this helps someone!

Ok, I spoke a bit to soon, This above just got me past the immediate crash. After logging on I would get a split second of zwift actually launching before it would just poof into nothingness, never to be seen again. The good news is I got it to work by additionally removing the signiture from all files (only the files, not directories) in the Application Support/Zwift/ folder. In short run this command one line at a time in your terminal and if all goes smoothly, your issue may be resolved.

replace “yourusernamehere” with your computer username
NOTE: some of these files may be named different on your machine, so just take a peek into that folder to confirm"

❯ sudo codesign --remove-signature /Users/yourusernamehere/Library/Application\ Support/Zwift/ZwiftApp
❯ sudo codesign --remove-signature /Users/yourusernamehere/Library/Application\ Support/Zwift/LauncherMac_ver_cur.xml
❯ sudo codesign --remove-signature /Users/yourusernamehere/Library/Application\ Support/Zwift/libant.dylib
❯ sudo codesign --remove-signature /Users/yourusernamehere/Library/Application\ Support/Zwift/libBink2Macx64.dylib
❯ sudo codesign --remove-signature /Users/yourusernamehere/Library/Application\ Support/Zwift/Zwift_ver_cur_filename.txt
❯ sudo codesign --remove-signature /Users/yourusernamehere/Library/Application\ Support/Zwift/ZwiftMac_1.0.100145_b450422b_manifest.xml
❯ sudo codesign --remove-signature /Users/yourusernamehere/Library/Application\ Support/Zwift/ZwiftMac_ver_cur.xml
❯ sudo codesign --remove-signature /Users/yourusernamehere/Library/Application\ Support/Zwift/ZwiftMacCrashHandler
❯ sudo codesign --remove-signature /Users/yourusernamehere/Library/Application\ Support/Zwift/ZwiftSetup.exe
❯ sudo codesign --remove-signature /Users/yourusernamehere/Library/Application\ Support/Zwift/ZwiftWindowsCrashHandler.exe