Zwift crashes on Apple TV

Yesterday I wanted to do a paced group ride with Maria. Zwift started up normally, I tried to enter the ride and Zwift shut down (back to Apple TV start-up menu). Three more tries, one with Miguel, same result. I gave up and started a free ride successfully.

Today I tried joining Maria once again. No go, Zwift crashed a couple of times. Again I tried to start a free ride, but today this also caused Zwift to crash. I ended up doing my ride on my android phone. Very inconvenient but at least doable.

Anyone else experience this the last few days? Is it a known issue?

The usual advice for mystery problems with Apple TV is to try a factory reset of the device. I suspect if your problem were happening to many Apple TV users there would be a lot more noise here and on Facebook about it.


Thanks, Paul, much appreciated. I took your advice, at least partly: First I started Zwift and tried to join a Robopacer just to be sure the problem was still present. Again, Zwift shut down. Then I followed your link, but I was reluctant to do a full factory reset due to the hassle afterwards. I opted for the alternative, a restart. After this, everything works fine. Well, not counting the fact that for the first few minutes, my legs weren’t moving, weird. That quickly sorted itself out. Ver 1.39.

1 Like