Zwift Companion Release, September 28th (3.18 iOS, Android)

Hey Zwifters, there is a small update for Zwift Companion heading to the Apple App Store and Google Play Store in the next few hours.

Here’s what you’ll find in Zwift Companion version 3.18.

  • Added a new filter option to show (or hide) Zwift Academy events on the event list.

If you run into any issues with this latest update, please let us know in the thread below.

Ride On :ride_on:

UPDATE (4:05pm, 9/29/2020):
We’ve released an updated version of Zwift Companion for Android to address the issue of the event list returning a network error if you had a pre-configured filter. Version 3.18.1 should be available in the Google Play Store soon to fix this issue.

2 Likes

Listing events now says network error since the update

6 Likes

Does this update patch the Uber Pretzel and Four Horsemen “No Badge” bug?

Yes it does, see the release notes in the other thread

1 Like

yup, mine too, android 3.18 just installed the update. No events listed. My meetups are still there however.

2 Likes

The apply filters button option on Android doesnt seem to work when only zwift academy is selected , as per attached it is greyed out

1 Like

you will need to also select the type of event like a race or workout. It would have been nice if you could only show the zwift academy events and no others.

2 Likes

Thanks!! Will do the Uber and 4 horsemen over the next few days. Last two badges remaining

CA map still broken - over 2 years and counting …

You have to clear cache(s) and then all good

Clearing cache did not fix it for me

OK, sorry bout that. Did you try re-install?

Ok yes uninstall and reinstall does work.

1 Like

I deleted data and cache. Re logged in and now it’s all good.

Two Android devices here and both getting the “network error” when loading events in CA.

3 Likes

@D_Byrne See above - delete your cache/date or reinstall. Had same issue on 3 Android phones and clearing cache/deleting data worked on all 3.

Just resetting the event filters in the app worked for me.

1 Like

Thank’s @_Dean_SAS. Deleted all files and logging back in worked.

1 Like

Companion map still not wirking after delete/reload.