Zwift Companion Release, February 25th (3.22 iOS, Android)

Possibly just on Android?

2 Likes

Here Android.
No flags anymore in ZC app.

4 Likes

All good on iOS both iPhone and iPad, flags show fine

Latest version of Android=no flags
ipad version is ok.

2 Likes

I’ll take the stable BT connection over flags :slight_smile:

1 Like

All - thanks for flagging up the flags missing in the Android Companion app. We’re on it.

6 Likes

This is is not resolved for Android.
Last night I could not connect my RUNN speed/cadence logger on my treadmill or my tickr HRM through the companion app. Tonight I am suffering BT connection issues with orange exclamation mark - again - by my Kickr core & Tickr HRM. I can ride - at least for a few minutes - but ERG does not work. Had issues on my last ride - Saturday evening - but was able to make it through.

Not sure what the problem is here. Seems like the last update messed with my companion-BT connection. Wish I could go back to Feb25. Hadn’t had connectivity issues in really the last 2 years.

Add me to the list of those experiencing connectivity and intermittent resistance issues (ie going uphill - no resistance on trainer, yet avatar slows in speed as if climbing). I’m not logged in on multiple devices nor dealing with interfering signals.

All the country flags now show as ‘no country set’ generic flag today, but that bug wasn’t there on Feb 28th. My Companion app was updated just before my ride today (9 hours ago from current time), so it appears to be related to the update. On Android.

5 Likes

About three posts up. :wink:

1 Like

Having the same Bluetooth problems as those previously stated and additionally I felt like I was in ERG mode on a regular ride today. No change at all with changes in elevation. Using Apple 4K tv and TACX NEO and companion app.

Stopped trying with zwift companion. Installed Zwift app on my phone (Samsung G9) and my trainer Kickr and Tickr paired immediately. Erg works but missing cadence. I can accept that. 7 mins into a workout and all is well – but small!! Hope this connectivity issue with Companion is resolved soon.

I access the Zwift game on my laptop via the Zwift Companion, residing on my iPhone. I have removed devices & reinstalled them. I have removed the Companion app and reinstalled the most recent version. At the time of this writing, I went from seeing every Bluetooth signal in my house to now receiving no signals at all when the Zwift Companion app is open. This is extremely frustrating and disheartening.

Hi!
I’m using the following setup since November 2020 on an almost daily basis:
Zwift App on Apple TV > Zwift Companion App on iPhone XS > Zwift App on Apple Watch 5 > Kickr 2020 + Climb + Headwind + Tickr Fit
I never had any issues or connection problems.
The morning of Saturday, February 26th I wanted to complete a workout from the 6wk FTP Builder Plan.
I set up everything as usual. When I started to pedal (workout warm-up phase) I realized that the ERG mode somehow didn’t operate properly. The App did not control the Kickr resistance as expected, even though ERG mode was displayed as ON in the Companion App. Switching it off and back on didn’t bring any changes. After a few more pedal strokes the Kickr resistance rapidly went up until I couldn’t push it anymore. The App displayed “ERG mode temporary disabled”.
So I quit the workout and tried all tricks I could find or think of to reconnect my setup (reinstalling all used apps, powering off all devices, reconnecting all devices, etc.), but the issue remains.
After trying to get it to work for over four hours I quit and spent the rest of the day with my family :wink:
Later in the evening I wanted to get my scheduled workout done, so I tried again, but still the same issue. So I downloaded the Zwift App to my iPhone, logged in and completed the workout on the iPhone with no issues. On Monday, March 1st the issue with my original ATV setup still remained, so I brought my MacBook ans installed the Zwift App to complete the next workout which worked without issues.
After the workout I realized that the workout I did on my iPhone wasn’t checked in the plan and was marked as expired. I still have the workout in my activities, but it somehow wasn’t accounted to my workout plan :frowning:
As a short temporary solution I could live with using my MacBook, but I hope the issues with my Apple TV + Companion setup will be fixed very soon!
Is there any way I can add the on workout I did on my iPhone to my workout plan? As I mentioned the full activity is still in my timeline.
Thank you guys for your help in advance!

2 Likes

Like others, no country flags showing in Android app, frustrating. This is a visual cue when sorting through rider list.

3 Likes

@shooj,

+1, this is really not resolved for Android. Can’t use Zwift properly since the updates in the companion app. Devices do not connect at all or lose connection mid ride. It is very frustrating.

Using Apple TV + android companion app, Direto XR, cadence sensor and heart rate strap. Everything worked really well last week.

edit:

It seems that the fix was applied only to iOS devices. The Android app is experiencing the same issues. We also need a fix.

コンパニオンのブロフィール画面で、国旗の表示がされなくなりました。
以前は表示されていたのですが、薄い白黒表示でのままで、各国の表示がされません

I can confirm the 3.22.1 update for iOS fixed the Bluetooth issues.

I also A/B tested pairing devices via the companion app vs just using the ATV & CABLE device and there is no difference in functionality either way. Scenarios tested:

  • Power pedals, trainer & HRM via CABLE to ATV
  • Power pedals, trainer & HRM via CABLE to companion app
  • Power pedals, trainer & HRM natively to companion app

I tested on Jungle Circuit climb. While still pedaling I went to pairing screen changed my pairings and then resumed. There was never a change in resistance or RPE with each switch. I will probably just stay using the CABLE direct to ATV since the trainer control works as expected. Thanks to @Moby_Parkes for alerting me to that feature as I had not used it previous with the CABLE.

Glad it’s all working!

1 Like

I use Zwift with the companion app on Android to pair with Bluetooth. I started having issues since the 27th of february. Before a race i had a really hard time coupling the trainer and during the race the connection stopped working completely.
Today with version 3.22.1 I was not even able to start a workout. The devices were paired (if we can say so) and immediately i got the No Signal message. I tried to reinstall, clean cache, restart phone and so on, but it would not work at all.
My trainer is an Elite Direto XR, which works ok with the Elite application. I saw that when this accident happens, the blue led on the trainer is on, as if the bluetooth is indeed connected, but there was no data exchange between Zwift and companion app.

As of now I cannot use Zwift