Zwift Companion Release, December 18th (3.20.2 iOS, Android)

Hey Zwifters, we’ve released a small update to Zwift Companion which should make its way to the Apple App Store and Google Play Store in the next few hours.

Here’s what you’ll find in Zwift Companion version 3.20.2.

  • Updated the Watopia map to include newly discovered roads.
  • iOS: Made improvements to the Club invite UI.
  • Android: Fixed a bug that could cause blank rows to appear in the Activity Preview.
  • Android: Fixed a crash when filtering events.
  • Android: Fixed a bug where changing password would cause an app restart without the password being saved.

If you run into any issues with this latest update, please let us know in the thread below.

Ride On :ride_on:

1 Like

Android 11, crash when press Filter button in Events.
EDIT: Reinstall ZC solved this.


Same here, on Android 10. App just closes instantly.

Didn’t do this before, so the ‘fix’ has broken it. :frowning:

Mine is not crashing in the events filter. I was able to change the parameters of the filter and reset the filter without crashing.


java.lang.RuntimeException: Unable to start activity ComponentInfo{}: com.f2prateek.dart.Dart$UnableToInjectException: Unable to inject extras for
at android.os.Handler.dispatchMessage(
at android.os.Looper.loop(
at java.lang.reflect.Method.invoke(Native Method)
Caused by: com.f2prateek.dart.Dart$UnableToInjectException: Unable to inject extras for
at com.f2prateek.dart.Dart.a(SourceFile:143)
at com.f2prateek.dart.Dart.a(SourceFile:87)
… 11 more
Caused by: java.lang.reflect.InvocationTargetException
at java.lang.reflect.Method.invoke(Native Method)
at com.f2prateek.dart.Dart.a(SourceFile:138)
… 17 more
Caused by: java.lang.IllegalArgumentException: Parameter specified as non-null is null: method kotlin.jvm.internal.Intrinsics.b, parameter filterShow
at Source:2)
at android.os.Parcel.readParcelable(
at android.os.Parcel.readValue(
at android.os.Parcel.readArrayMapInternal(
at android.os.BaseBundle.initializeFromParcelLocked(
at android.os.BaseBundle.unparcel(
at android.os.BaseBundle.get(
at com.f2prateek.dart.Dart$Finder$3.a(SourceFile:198)
at com.f2prateek.dart.Dart$Finder$1.a(SourceFile:187)
… 19 more

Reinstall resolves the error as suggested by @Tomas_Knapko1393. :+1:

Reinstallation also worked for me.
Pixel 3a
Android version 11

Android users who’ve experienced this crash in Android version of Companion v 3.20.2:
The fix for this will be in the next Companion release.

A workaround for now is to clear the app cache for Companion. Depending on which version of Android you’re using, it’s something like Android Settings > General > Apps > Apps Info > Companion > Storage > Clear cache


1 Like

Mine keeps crashing on the filter selection, even after clearing the cache.

I’ve been doing some meet ups during the pandemic and it’s been a great way
to stay in touch with people. In the past, when I clicked on “Do it Again”, it would auto populate the list of riders from the previous meet
up. Now, it only auto populates about 4 of the 70+ riders. Is there a plan to address this in the Companion App? Thanks for your help with this.

When I click the ‘filters’ button under events, my Companion App crashes. Android (latest version)

I had this issue as well. I uninstalled the app and then installed again and it has resolved this for me.


It’s broken now. iOS

Apple Watch not pairing to Zwift companion. :-1:t2::grimacing::worried:

Zwift Companion cannot maintain Bluetooth connections at all. This makes the app pure garbage if this basic needed functionality does not work. Get this fixed ASAP or you have lost a previously loyal customer

1 Like

Our first 2 weeks went well, but the last week was terrible! Devices are connected, but during the ride the power drops to 0 and so you stop. Looking at the device connection all is ‘blue’, so ther is connection, but it says: “no signal”. Then it comes back, you start again but within a few seconds it’s zero again! Very frustrating. What’s the problem and how to fix?

1 Like

Hi everyone! I’m having the same issues with Zwift. The app gets disconnected in the middle of the ride without apparent reason. I’ve tried 2 different iPhones, iPads, Apple TV’s and even an android… I opened several tickets with support and I haven’t received any answer from Zwift. Very dissapointed from customer service… I got fed up and changed to BKool app which offers a comparable service without the glitches Zwift has and it is 5€ cheaper per month.

Zwift team, the overall idea and community of your app is great but your customer service and the several glitches on your platform are dissapointing! Hope you improve both…

I recommend you go try Bkool… i didn’t have any issues with you equipment with this app. This is a glitch on the app on the latest release.

Same here! I already changed to BKool! The app works well and offers the same functionality