Zwift Companion Release 3.42 [November 2022]

Hi Zwifters! These are the notes for the latest updates to the Zwift Companion app version 3.42.

Android version 3.42.0 (1477)

  • New Discord link integration for Clubs
  • Fixed crash on Android when adding ride leaders in Clubs

iOS version 3.42.0 (1361)

  • New Discord link integration for Clubs
  • Fixed an issue on iOS for event reminders
  • Improved map rendering on your activity highlight on iOS
6 Likes

Note, add your club’s discord link in the Club settings in the companion app. I believe you need to be the owner of the club to do this, then you can choose to include the link in club events.

I pasted a discord link into club chat and it didn’t work.

1 Like

Club owners and moderators both have access to add Discord links. This Support Hub article will guide you through it

Can you give an example of a discord link as i’ve tried both with and without https and getting only discord links are allowed

I just setup a test Club to test connection to my test discord server and seems to work fine - you are welcome to try it

httpXXXs://discord.gg/KNrwCeyzhE (remove XXX)

To get the address of your discord server, just do the first few steps below:

Highlight the server you want …

Click here …
image

then …

Then this pops up - just make sure you click the “Set this link to never expire”

1 Like

strange, exactly what i was doing last night i thought but seems to have worked now so all is good.

1 Like

Hi @shooj

Not sure its related to the latest update to the Companion App or not but since the latest update, the blue zwift backwards cap in the garage is no longer available.

Zwift (latest version) running on macOS Ventura
Zwift Companion App (latest version)

Thanks,

Chris.

This is a known bug, log out of Zwift and back in and the hat will reappear. It happens anytime a new helemt, hat, visor, etc. Is added to your garage.

Thanks Mike :slight_smile: A few of us in that thread have figured out that’s what’s happening, yep. Although ime it’s not happening with every new bit of headgear, but it happened with the Makuri visor too iirc. They do always come back, though.

Can the Discord link be accessed once the event has started as the Event page will disappear once it has started on Companion App?

Does it appear on the Companion App Game area then? I do not seem to see it anywhere once we rolled out from the starting pen.

If I scroll down to the bottom of my club’s page in in ZC then I can see the Discord link there. I’d be surprised if it’s only showing me that because I’m a club owner.

On my Android, the companion app is not showing the Game when I’m signed on and riding. I can’t chat or give ride ons. It waa fixed and now its broken again.

1 Like

This is caused by your phone not being able to see your Zwift game device on the local network. So it’s a local issue - make sure your phone is on wifi. Has this issue just started happening, and if so has something changed on your network?

Another possibility is if there is dual wifi bands being present (2.4 GHZ and 5 GHz). One device could be on 2.4 GHz while the other is on 5 GHz. You need to ensure that both are on the same band besides the wifi being present.

As long as the devices are on the same IP network and nothing is interfering with the traffic, it doesn’t matter how they are connected to the network. Mixing wired and wireless is fine as well.

4 Likes

In my case it helped disabling the mobile data für the Companion app. So it is forced to communicate over Wifi, connects much faster and is more robust.

1 Like

I have this problem also. My wifi doesn’t have options for different bands.

So with iOS I have to close all data and mobile connections and restart the companion app, wait for the connection error, refresh multiple times then enable wifi and Bluetooth then eventually app will connect.

How do I end my workout on my Apple Watch? It still shows in game, even though the Zwift game/activity is done.

I just spent over 2 hours troubleshooting network, installation, equipment and dongle possibilities for not being able to connect the Companion App. As soon as i turned on airplane mode and enabled WiFi… boom i was connected! This is bonkers! There must be a better way.