Zwift cant find BLE Stages PM. Tried everything! Argh!!


(Parichit Bagga) #1

Zwift cant find BLE Stages PM. Tried everything! Argh!!

Hey folks, as the title suggests…I’m having a hard time getting my Zwift App to find my BLE signal from the Stages PM.

Basics:

  • I’m running Zwift on Windows, and my phone is Android.
  • I’m pairing through the app, not directly from the PC.
  • The stages PM is discoverable by the phone when i use the Stages PM app (strictly for testing, to calibrate, etc.)
  • The stages PM shows up in my list of available Bluetooth devices on my phone, but again, im not pairing from here…i am using the Zwift app.
  • My phone pairs with the game correctly…as i can see the ringing phone/Bluetooth icon on the pairing screen which indicates the game is connected to the app.
    But when i click to search for a power meter…nothing shows up.

Here’s what I’ve tried so far to troubleshoot:

1.) Made sure all other WiFi/ BLE signals nearby were off.
2.) Replaced the battery on my Stages PM.
3.) Made sure the phone doesn’t have too many paired devices (other devices ive used in the past)
4.) Made sure the firmware in the Stages PM and the Zwift app are up to date.
5.) Ive tried this in different houses with different Wifi settings …there is no additional security except a standard WPA security password to connect to the internet.
And like i said, the app on the phone and the game on the PC connect just fine via WiFi. Its just the damn Stages PM that cant be found in the pairing screen in the game!!

The whole point I’m trying this BLE connection is because the ANT+ signal from Stages keeps dropping on the Zwift app. Its highly annoying. I don’t want to purchase a 10 ft long USB cable and place it under my bottom bracket where all my sweat goes and risk someone tripping on the cable.

 

Im frustrated. Please help!


(Cary Sporinsky TeamZF ZHR(F)) #2

sigh.

you don’t have to place an Ant+ sensor underneath a bike where it gets sweat on it. A 10 foot extension is too long anyway, you might get signal loss. One meter between sensors seems to be just fine. The ANt+ sensor seems to like being higher too. Never, ever have I had an ANt+ signal loss.

You’re going to stay frustrated if you don’t get the Ant+. Your reasoning is flawed. Connecting Zwift through a device to Windows is just asking for trouble.

Be sure you have any firmware updated. I’d say you have an incompatible device, but you are connecting other sensors to Zwift through it(?)

There is a list of devices with issues. You really need to include this sort of info when asking for help. I am guessing that is your problem (incompatible device)

 

Good luck! I am thinking of buying the Stages. I love knowing my w/kg and I want to take that outdoors with me.


(S imonN (PACK)) #3

Hi,

I am having pretty much the same issues. I have a Stages powermeter and a Wahoo HR monitor. I connect the HR strap via ANT+ but have to try to use BLE for the powermeter as I get continual drop outs if I connect the powermeter via ANT+. I have tried an extension cable for the ANT+ stick but that makes zero difference. It is odd but I use the same setup with TrainerRoad and Sufferfest and have no issues with drop outs on ANT+ in those apps, they are both significantly lighter from a processing overview standpoint so that may be the issue.

So then using BLE is the only option but it is not a reliable option. Sometimes it works perfectly, I start ZC then Zwift and it immediately picks up the HR strap on ANT+ and the powermeter on BLE, sometimes it just will not see the BLE connections, for reasons I cannot understand. I spent almost an hour last night trying various ways to connect, eventually it worked but I am not sure what I did. I am on iOS not android but my current process (as of last night) is to completely shutdown both the PC and the phone (yup - turn it OFF) then restart the phone, start the PC, start ZC, then once that is up start Zwift and pray for a BLE connection.

I do think there is an issue that Zwift need to look into. Using ZC to connect BLE devices to the main PC running Zwift is accepted/recommended practice but seems to be fraught with challenges.


(Paul Allen (Watopia Wayfinder)) #4

S imonN (PACK),

Have you gone through the troubleshooting steps on this link for the ANT+ dropouts: https://support.zwift.com/hc/en-us/articles/204186849-My-ANT-signal-is-dropping?section=201145295