Zwift App keeps crashing



I’ve only just signed up, but everytime I click on the Zwift Icon, the app opens up, lets me sign in, then shuts itself down. A little frustrating as I’d love to give the software a go!





Unfortunately, I too have the exact same problem.  Thanks for asking the question.


I’m very sorry you are having trouble launching Zwift. Can you both please open a support ticket?

Please include the ComputerSpecs.txt, Launcher_Log.txt, and Log.txt from your Documents/Zwift/Logs folder.


Same here after updating win10 and some drivers/updates. Will log a ticket :slight_smile:

exactly same problem here and no help with ticket. about to give up on this :frowning:

I figure it out, so the problem is that zwift is not updating itself. I figured this out by installing zwift on my other desktop. Installed fine and updated itself immediately. On the problem desktop it did not update.


The way I got around it was to take the files from the working desktop and copying them to the desktop that did not work. Now that it was updated it worked just fine. Of course this is not optimal and you will need zwift on a computer that works so you can access to the files.


zwift app should download with all the updates and not as an old app and then download updates after the app installs.

Hi everyone,

Lindsay in Quality Assurance here, pitching in to help our Customer Service department. I understand your frustration and feel for you. We want you in Zwift! We test as best as we can to ensure that you’ll get in without issue and most of our users do. From what I’ve seen in testing, uninstalling and reinstalling usually works like a charm – so long as after uninstall you delete your Zwift folder from the programs file, as well as the Zwift folder from the documents file, then reinstall the latest available version from That usually does the trick.

But if it’s still the case that you can’t log in after signing in to the launcher, then it’s something else. I have some ideas… Please try creating a new account and see if that will log in. There may be something about your specific account that can’t log in – so please try that.

I really hope this helps. We want to see you on Watopia and we’ll do whatever we can to help. Thanks so much for your understanding and patience. We’re doing our best here to support the Zwift community.



1 Like

I’ve uninstalled and re-installed at least 4 times. I still get the application crashes. I’m curious as to what files need to be copied as mentioned in Paulo Dias’ comment.  Can anyone please shed some light on this and be more explicit as to what files to copy and their location?

In order to use this workaround, I guess the first step is to get it working on another Windows 7 machine in order to get those files so I can copy them to the other Windows 7 machine to get it to work.



I just installed zwift on another computer that works and then copied the whole folder to the computer that doesn’t work. It worked great until there was an update, after the update certain things would not work so I had to repeat the process. I think we are having a problem that zwift is not able to update, I am not sure what is causing it though, still trying to find out.


I filled a ticket and I was told to update zwift through the launcher before launching it, I did so but still did not work, says zwift up to date but it won’t update apparently as it will crash. When I update zwift through the computer that works you can see the update bar when zwift launches.


This is really annoying but at least I got it working, even though I will have to repeat the process everytime there is an update. Would love to get an answer to this as well.

Thank you very much for this information.  I was able to get Zwift working on my Windows 7 laptop after copying it from another Windows 7 laptop.

I got Zwift to run after doing these things in this order:

  1. Updated my Windows 7 OS software (last update was 2011) – tried and Zwift still crashed.

  2. Copied the entire directory c:\ProgramsFiles(x86)\Zwift from a working Windows 7 laptop (I just installed it and it worked without problems on that laptop) to my non-working Windows 7 laptop (after removing the existing Zwift directory).  I also removed c:\Users\xxxxx\MyDocuments\Zwift on the non-working laptop.  I then restarted the launcher – Zwift still crashed.

  3. Updated my drivers on my ATI Mobility Radeon HD 5470 graphics card on my laptop.  I started Zwift again and it finished starting up.

I was then able to do a ride.

Hopefully, if there’s a Zwift update, the update will work; if not, I can just copy the whole directory again.

Thanks for your help.





Glad you got it working Dennis.


I don’t think the updates will work, something must be blocking the program from updating (mine is windows 10 so its not a windows version thing).


But worst comes to worst we can keep doing this and having it work, annoying but at least it works.

Zwift app crashes (locks up) during workouts. Problem is sporadic but I lose the entire workout because I have to close the app. Very frustrating especially when the workout is GONE! Ideas?

Program on PC freezes up and kick you out of it. Then workout file is also the corrupted when trying to download it.

I had the same problem Gert, 4 min remaining on a FPT test have to look else were for a programme that does not crash

I have tried new accounts and support tickets, Zwift told me it was my nvidia card and then left me with nothing else to go on.  I get about 60 seconds and then my app crashes.  I want my money back…