Zero distance FIT file

The latest Zwift update has major issues. I did the Specialized Roval Climbing Challenge today on the Ven-Top route (that climb is a bear).

The Zwift activity log shows the correct data, but the FIT file uploaded to Strava and Garmin Connect shows zero distance. I downloaded the FIT file on my own & tried it in Golden Cheetah with the same result - zero distance.

This is especially strange because I did a warm-up ride that uploaded just fine. I had to exit the app for a min (exit was not Zwift related), got back in and after Watopia loaded I chose to join the event. Everything seemed fine during the event…looked at Strava afterward & the disappointment began…all that work and zero bragging rights :wink:

Not sure if it matters but I am using the new Apple TV 4k to Zwift


Probably best to add your voice to the main thread that captures this issue …

1 Like

Hi Dean, much of the same problems as you, no transfer of data to Strava, Training Peaks and Garmin with the new update. Hope zwift fix soon as, cheers

1 Like

Same here - seems to be related to group rides.

Same thing happened to me this morning, I did a group ride and zwift recorded 0 distance and elevation. Hope zwift fixes this issue quickly. thanks

3 time same happen :frowning:

See Unable to download a ride - and it didn't auto-upload [July 2021]