Z117 at Line 602

Getting an error trying to install Zwift: Z117 at Line 602 in patcher.cpp. I have been trying to install Zwift on multiple PCs. I’m fairly new to zwift and have thus far only been running on android tablets. Have tried multiple Win 10 PCs and tried the solutions suggested in for the Z117 in support

So far on my laptop I would prefer to run Zwift on I’ve:
Disabled syncing of the documents folder
Tried running the installer as admin
Turned off antivirus
Ensured adequate free space on the HDD
Deleted all zwift folders and tried again after the above steps.

I’ve also tried basic installs (without all of the above steps) on two other machines with no luck there either. they all get the same error Z117 at line 602 in patcher.cpp

Did you try this:

1 Like

The same problem with my second device (W11, SurfacePro6)
I appreciate getting tipps for solution.

@Mike
This workaround doesn´t work for me.
Finally the app crashes always after klicking the button “LET´S GO”

Even a complete deinstall and reinstall routine had no effect.
There´s no way to let it work on my SurfacePro right now.

some of the Zwift support staff have mentioned that this usually happens when Zwift is denied writing to the documents folder, do you have anything preventing that from happening like a cloud sync program?

I´m afraid that´s doesn´t help in my situation.
I have Zwift running since two years on that device. The error accured during todays update session. I´ve done similar updates without any problems several times before on my Surface.
I guess that the error has something to do with Windows 11.

Hey Guys,

I have identified my problem related to the error message Z117 line 602.
My firewall (palo alto) was dropping the traffic to clientXzspeed-cdnXcom
modify X to . (unable to add url into the post.
Due to Proxy avoidance.

I added the url to my whitelist and zwift started installing properly.

Grz,
Fabio

1 Like

Been having all the issues as stated above, once I move the Zwift folder from Documents to the Program Filess (x86) what’s next? There seems to be a need for a step 5 here. Does it just magically start working?