Z112 Error on launching line 602 with patch.cpp


(Gavin Williams) #1

Hi All,

Reaching out in this forum because Zwift.com doesn’t reply to my emails.
I’ve tried to installed Zwift to go with my wahoo kickr and it just keeps stopping and crashing out at the first install.
For context, Desktop PC is Win10 and I have tried as follows:

Tried Once
Tried with AV stopped and Onedrive stopped.
Tried with Onedrive exited
Tried with PC unlinked from Onedrive
Tried deleting partially downloaded files and redownloading.
Tried on my Surface Pro 2017 laptop
Tried as above on my surface pro laptop
Blatted my surface Pro laptop and reinstalled windows with defaults and not onedrive-d
Installed Hyper-V on desktop
Installed windows 8.1 on virtual machine in desktop
No Onedrive and no AV.
Error same place same line.

Tried not using my broadband router and running on my cellphone hotspot.

Zwift not replying

Any joy?


(Xan Megaman) #2

I have the same problem and it has appeared after the last update. At this moment I was not able to make it run…


(Vincent W.) #3

Hey @Gavin_Williams I know you tried deleting partially downloaded files, but have you tried completely uninstalling your Zwift application then reinstall from a fresh new download?

Also, have you checked out our article on the error? https://support.zwift.com/en_us/error-code:-z112-(cycling)-H1bcm0ybr7

@Xan_Megaman


(Dibbo) #4

Same problem hence trawling the forums . . . uninstall and reinstall doesn’t work.
I have even manually removed the registry entries . . nothing.

Nothing on my pc has changed since last Zwift update (I use a stand alone laptop just for Zwift no networked drives or any of the issues Zwift list on the referenced support article) so the problem must be in the original Zwift download file, or the Zwift server partially delivering/ stalling the download, not the receiver.

There must be a hidden file or registry entry issue that needs to be removed before the download will authorise and install???

Never had a problem before but this is really giving me the shits as I can’t use Zwift, I can’t reinstall, I can’t find a resolution . . .

I’m not a tech newbie and I’m stuck in an endless failure loop now and pretty sure it’s a software problem from Zwifts side?? I’ll have another go at downloading again now, but my hopes are low Zwift have not found the bug in their software.

Frustrated.


(Xan Megaman) #5

No way.

I have completely uninstalled the program and reinstalled from cero but during the update the issue appears again, blocking the launching of Zwift.

I’m in the same situation as my partners, at this time without any solution and just in the middle of the cyclocross season without training possibilities…

Frustrated +1


(Dibbo) #6

Solution found - changed from normal wifi to phone hotspot and it worked.

It seems root cause is a bad internet connection and high latency causing drop out in the download and the permanent loop of Z112 failure.

Zwift support were good and recommended I go to speedtest.net (using Los Angeles Server) - alarming to see a ping of 172ms and download speed only 5.54Mbps!! Bloody ■■■■ no wonder such a big file failed.

Here’s what I did:

  1. Uninstalled Zwift, removed Documents folder & logs, Programs folder, everything (except registry).
  2. Reset modem, router, whole network with a full power off.
  3. Rebooted computer while modem off and then I switched a different internet connection using my phone hot spot with a ping 23ms & download 40.48Mbps
    Note: Stayed off wifi and on phone hot spot from this point till end
  4. Started the www.zwift.com/download and opened the loader as normal
  5. Once loaded went through normal procedure and it worked.

Note: Problems were updating to 1.0.44 and file that loaded was actually 1.0.31087?

Anyway who cares as back online after a few frustrating days and way too much time trying to get this working with countless uninstalls and downloads.

So bottom line do a speedtest as it’s probably a slow internet connection with high latency causing the dropout in the download file and hence the error.

Wish I had seen this solution a few days ago. Hope this post helps others searching for this problem in future. Ride on baby!


(Gavin Williams) #7

Hi All,

I fixed it in the end… the problem is with Zwift’s CDN (content delivery network). It looks like it’s only partially replicated.
When I tried to download from my ISP #1… it would get about halfway, then be missing a file because it didn’t exist on https://cdn.zwift.com (Innsbruck lamps.GDE)
Then when I tried (twice) to download from my tethered mobile on Vodafone (ouch data charges), it would get further before it would stop again. Clearly the Vodafone network path to CDN.zwift.com takes a different path.

Finally I took my laptop down the street to another neighbour who was using Virgin Active as his ISP… the whole thing came down seamlessly and installed on the laptop, (so clearly using ANOTHER CDN.zwift.com).

Once that was done, I then copied all of the files from laptopc:\program files (x86)\zwift to USB… copied them all across to desktopc:\program files (x86)\zwift, deleted all the partially downloaded files on the desktop and cleared logs… then launched.

so if you’re REALLY stuck… then try using another ISP or else us a VPN to another country to get to it from there.

Please note… there’s some notes on the other threads about ISP compressing/caching etc. and patcher failing because of CRC checks… this is not the case here… the files SIMPLY DO NOT EXIST AT THE DOWNLOAD LOCATION. (I also did extensive tech discussions with my ISP who have strong tech support and root-cause analysis people). Definitely a Zwift problem.

So now it’s working fine and will continue to work fine until zwift do a software update in which case I’m pretty sure it will crater again until I go wandering around houses trying different ISPs.

Final note: Support.zwift.com have still never bothered to answer my direct queries including several log files from different computers which would have instantly showed that the standard answers in the article are not relevant, so they clearly are either understaffed or just don’t give a toss. (@vincent - yes I did try all of those actions, several times including as mentioned in the support queries going as far as reformatting laptop HDD and reinstalling windows from scratch. waste of time that was!)

Gavin