WTRL Zwift Classics Signup problem

Hello all, wondering if you can help me?

I have been trying to signup for the WTRL Zwift Classics series but every time I click the join button I get the following error message.

This is the first time I have entered a WTRL race before but I do have an existing Zwift Power account that is public and linked to Zwift. I have successfully used this to race in other events.

I believe that I have completed the WTRL profile details correctly, I have added my Zwift ID and when you click the link on the profile it correctly goes to my Zwift Power account.

However, the link that is shown in the image “You can check your Zwift Power profile here” does not have my Zwift id in it.

I was hoping to race in the first event this evening, hoping someone can help. I have also tried multiple email addresses with no luck.

Kind regards,


FWIW I just joined and it worked absolutely fine for me.

I have the exact same issue, all my accounts appear to be setup correctly and I get the same message! I was hoping to start the race 15 mins ago :-(. I hope someone can shed some light so I can join the next one!

ps sorry I can’t help solve it.

Thanks, Dave, I just double-checked my settings and tried again, still no luck.

JC, I also mailed the WTRL team, will let you know if I have any luck there.

Kind regards,


Are you putting in your name and 6/7 digit Zwift ID exactly as they appear on ZwiftPower, and double-checked there are no spaces etc? I can’t find you on ZP, which may be the problem.

I believe so, my name on Zwift Power is just Nic Jackson, I don’t have my Club appended to the profile name, that might be a problem. I think I do have the correct id though, I just copied it from the profile in Zwift Power.

Profile ID: 795860

Really appreciate all your help, I spotted a mailing address for the WTRL team and they are also trying to help

Kind regards,


From speaking with Martin at WTRL (who are awesome BTW), my problems are due to not having any previous race history in the last 90 days. This stops WTRL from categorizing me, which makes sense.

To fix this Martin suggested entering another Zwift race or event over 20mins so that it adds the necessary data into Zwift Power. I am going to do that this evening. @JC_Madds you might have the same issue.

Thanks for all your help,


Ah, I was looking for Pearson. :wink:

The error message you’re seeing could probably do with a minor tweak for clarity if it’s specifically to do with lack of recent race results. :+1:

1 Like

The FAQ could use a tweak too. It should switch the word ‘recommend’ to ‘require’

1 Like