Workouts with intervals are not properly adjusting interval speeds [1.15.0] [July 2021] [SOLVED]

After the upgrade uploaded interval running workouts have a problem. The workout looks as expected when selecting the workout. However as soon as you start the run, the interval shows for both OnPower and OffPower the same speed.
It looks like all interval workouts are affected, including the standard Workouts like Norseman 2020.

I also noticed this on a workout tonight … so this issue is Bike and Run related.
The intervals worked fine when you got to them (showing the correct wattage while you were on that interval) but the checklist on the left was showing the same wattage target for the ON and OFF intervals before you got to it…

Not a big bug, but worrying when you are scanning what is coming up in the workout and not seeing the rest target between intervals, :rofl:


Similar issue. See how interval wattages are off

If anyone else sees this when doing a workout, please add screenshots here so it gets picked up and fixed/corrected in the next patch or update. Thanks. Ride ON! :+1:t3:

My Android update won’t even open so I’m not seeing anything :slightly_frowning_face:

Saw it last night. Only interval display list on the left was wrong, correct power was displayed when you got to the segments.

Same problem for me this morning, running on MacOS.

Same issues this morning on my MAC after completing the latest upgrade.


Thanks everyone for adding screenshots to highlight the issue.

@joules / @shooj … Please ask if you need any further detail and update this thread to confirm this is being looked into and a fix incoming!

[Edit: I see this is now flagged as a ‘Known Issue’ so I suspect the team are looking into this, but always good to be kept updated!]

Many thanks :+1:

Yes, we are working in it!


Same issue for me, on two different Macs, on all 3 workouts tried. First noticed 36 hours ago by my daughter (child account) then 12 hours ago by me. Issue reported to Zwift, which led me to this forum. Workout runs properly but workout preview at top left of screen displays incorrectly.
There may also be a problem with the gantry power zone colours not displaying the correct colour, but I need to double check that.

Just installed the latest update this morning to my MacBook and noticed there was a strange error with my custom workout. My workout had 30x30 intervals and Zwift would only display one number for the entire set. So instead of 30 secs x 250 watts/30 secs x 125 watts, it was displayed as 30 secs x 250 watts/30 seconds x 250 watts. ERG mode did change correctly to adjust for the 30 seconds of rest but I thought it might be a good idea to have it corrected.

I had the same issue with the regular zwift workouts this morning. The SST (Short) which is 4 x (5 min@300W + 5 min@275W) was displayed as 40min @ 285W. Tried several other workout and anything with a repeated pattern showed the same way. Just found another workout so don’t know if it was a display issue only

1 Like

Same issue - PC version. Repeated intervals (e.g. 3x (1 min @ 105% 1 min @ 95%) ) show on left hand side of screen as at power of first part of interval. Doesn’t affect what happens when you get to that interval - it sets the required power to the correct value, it’s just in the workout overview.


Same here! I know the Zwift team probably have bigger bugs to fix but just thought I’d mention it.The rest intervals do show up on ERG but it’s just nice to see them on the overview. It’s just a mental thing for me I think :slight_smile:

1 Like

Thanks Steve! I didn’t see that thread before posting.