Workout pause on Companion not reliable


(Justin MV (Ride GG)) #1

I’m having an issue where the Workout Pause button on the iPhone Companion app in the Workout screen does not always work properly. Most of the time it does work, and allows me to “pause” during a hard interval and get in a few seconds of easier pedaling and then ramp back into the workout interval. 

But sometimes the pause button has no effect on the trainer and only pauses the workout clock. In these instances, the trainer (Kickr 2017 in my case) continues to hold the workout wattage as if nothing happened. This gets me into trouble because I usually only use the pause feature if I’m tapped out and absolutely need a rest, but then it doesn’t work right.

I haven’t fully tested, but yesterday when this happened I had pressed the button and nothing happened immediately, so I pressed it again. But then it caught up and paused then immediately back unpaused. So when I pressed it a third time to pause again, Zwift did not reduce power as expected. I waited for another 30 seconds and tried again, and this time it worked. 

Thanks!