Won't launch, only downloading — never Zwifted, very bummed

So all of this hype about Zwift, and then I try to install it on Mac and it won’t finish downloading. It’s stuck at like 74143539 minutes.
I am not installing on iCloud, though I would like to have my Documents on it, but Zwift won’t allow to install on a different folder.
Already uninstalled and reinstalled it, but not working.

Can someone help me, I’m losing my excitement for this app…

Hi @Mirco_Oliveri_Sofia, welcome to the forums. Can you give us more details about your Mac? How is your internet speed, using a VPN? The more details you can provide the better for us to try to help you.

No VPN, great internet speed, I’m on Sonoma latest version. I had no problems with Rouvy, it works like a charm. I can stream anything with no lag.
Latest Macbook Pro 16".

Not sure what else I can provide you with

Did it ever finish downloading and updating?

Check out this support article, something about icloud or Apple private relay is actually a VPN, maybe that is holding it up?


Sorry but I have my whole computer on iCloud, and if Zwift cannot work with that I don’t know what I can do. Especially when Zwift won’t let a user choose where to install itself to do it outside of iCloud.

I guess I’ll stick with Rouvy, thanks!

You can use iCloud without using Private Relay. I have iCloud enabled, on Sonoma, and have not experienced any problem with Zwift. I don’t use Private Relay. Occasionally I have used a VPN while on Zwift and that worked fine. I’m not sure what you’re running into. Do you have any anti-virus or digital loss prevention software on this system? I’ve had no problems with Microsoft Defender and Zwift but there is a lot of dodgy anti-virus software out there that can interfere.

iCloud’s private relay is off, and I never use a VPN.
I’ve no antivirus, no firewall enabled…

It just won’t work ¯_(ツ)_/¯

One last thing to try for installation would be using a different Internet provider such as by tethering to your phone. Then switch back to your high speed connection to run it.

I’ve tried that too, but the same happens