Windows 10, Bluetooth dongle failed pairings with workaround

Hi there, I think I’ve found a bug (as well as a workaround) with the latest version I have a bluetooth dongle, which works perfectly with Trainerroad and my Kickr17. Reboot PC, load Zwift instead. Select internal bluetooth, Zwift doesn’t see any devices including Kickr17. Switch to Zwift companion app, it then finds devices and allows pairing. Disconnect devices, switch back to Internal Bluetooth dongle, it then finds the Kickr.

Has anyone else found this?

Welcome aboard!

For a long time now, I have been able to directly attach my devices using my laptop’s internal BT device (though I did go the Companion path in the past as well.)

True, I started experiencing disconnects a cupule of months ago, for which I am looking for a solution (not a workaround, mind you…), and I attribute this to Zwift issue - not some H/W problem (I may be wrong here - but others are having similar experience)

In short: yes, I would say this is a known (as in “the issue has appeared in forum postings”) issue, one that Zwift should fix.

Unfortunately I have discovered that my workaround, isn’t a workaround. When you tell Zwift to use the Internal Bluetooth it continues actually continues to use the bluetooth on the phone, even if the companion app is closed. I confirmed this by turning off the Bluetooth on my phone to find that Zwift now shows “No Signal”.

I’ve installed the Visual C++ redistributables. The bluetooth dongle can be seen in Device Manager. The Zwift logs don’t show the blu*.dll load error, but do state that Bluetooth is turned off, when it clearly isn’t.

Problem solved! It was the BT dongle. I run Trainerroad and Zwift at the same time. Trainerroad recommend the BLE112 dongle. This doesn’t seem to be recognised by Windows 10 as a full Bluetooth device and Zwift doesn’t recognise it.

Luckily I had another dongle laying around, an ASUS BT-400. Zwift does detect this and uses it properly (only with the VC components installed). Trainerroad will also use it.