Virtual gears display on update

Logged in for the 7pm EST Tour B ride and I had an app update. Now I am displaying virtual gears just below my power with no ability to change them. I’m pedaling like crazy and going nowhere!

Anyone else with this?

Hi @Jon_Rad, welcome to the forums! It sounds like you’re on a Zwift Hub (firmware 5.2.2) with the Zwift Play controllers paired. You can now use the shoulder buttons on your Play controllers to control virtual shifting (FAQ here for more information). If you wish to stick with physical shifting, you can disable virtual shifting from the Zwift Settings menu.

1 Like

When I started Zwift today, I got a message asking if I wanted to enable virtual shifting using Zwift Play and when I said yes, it took me to a tutorial screen showing me how to use the shoulder buttons to control the shifting. I couldn’t find a way to leave the tutorial screen and my Companion App seemed to be frozen. I quit CA and Zwift and started over but no longer saw the query about using Virtual Shifting and the shoulder buttons didn’t shift my Hub. Not sure what to do next.

Was the gear showing below the upper left info display? If not, it may have disabled and you would need to re-enable it in your settings.

Yes but the gear has been showing there for as long as I’ve had the Hub (Classic), so about a month now. But it just stays at Gear 12. Today was my first Zwift ride after the latest update and it’s the first time I’ve seen the message asking if I want to use Virtual Shifting. Even though I pressed the A button to confirm (as I was prompted), I couldn’t get past the tutorial screen and now the Zwift Play doesn’t change the gear - still says Gear 12.

Now it’s working. I went to settings and turned off Virtual Shifting and then turned it back on and it started working.

1 Like

i always use virtual gears, today started the TDZ and no gears…. late joined ride, and still no gears ( was put in front A group !)
menu buttons worked on controllers.
Restarted imqc computer logged in and… i have gears !
havent changed anything
waiting 45 minute for next ride start

Make sure you’re always pairing the trainer through Bluetooth and not ANT+. The virtual gears don’t work on ANT+.

1 Like

thanks could have been the problem, but not sure why it changed .

never understood why add in gear buttons didn’t interface directly with zwift hub.