Using Zwift Mobile App as controller


(DB Smith (65+)) #1

Scenario:

  1. (Mac) Computer running Zwift upstairs

  2. Kickr downstairs

  3. Apple TV downstairs

I’d like to be able to log into Zwift on the computer upstairs but then go downstairs to start my ride. The laptop finds the Kickr and streams to the TV, no problem.

But the Mobile App (v. 1.4) isn’t giving me ANY “control” functions – the dashboard isn’t there and I can’t even find a way to begin the workout.

Both computer and iPhone are on the same wifi network.

I’m probably missing something simple – what is it?! 

Note that I’m trying to set this up before actually getting on the bike; could it be that the mobile app control functions only work when I’m on the bike and pedaling, with the ride started?


(Jimm McElroy) #2

Yes. The mobile app is just an in-game controller.


(DB Smith (65+)) #3

Did a ride but could not make the iPhone app do anything.

Logged onto the game site before opening the app – is there some sequence to opening these things?

Ride worked fine; iPhone app gave me nothing.


(Brian Gorby) #4

Hi Dana,

Feel free to open a ticket with us (http://bit.ly/ZwiftSupport). Mention my name in the ticket so it gets to me, and we can diagnose what the problem might be.


(Y ohans) #5

I’m confused with this one yet curious.

It seems you are trying to do a workout remotely. If so how are you going to see what you have to do in the workout e.g… power/time intervals etc. This is displayed on the game screen. In your case upstairs.

How is the ANT+ connection working for you? I’m assuming the ANT+ dongle is on the computer upstairs or is it? Every post on ANT+ is suggesting to use an extension. You must have a really long extension ???

 


(DB Smith (65+)) #6

Yo Hans,

No mystery/magic:

It’s a pain to have to move my laptop to my exercise area every time I want to ride Zwift. The Garmin ANT+ USB picks up the Kickr and I can stream Zwift using AirPlay from where the computer normally sits. All I need/want is a controller.

Yes, I’ve seen a lot of recommendations for a dongle extension; as noted, the Garmin USB seems to find the Kickr beautifully, with a strong signal. Same for AirPlay – works fine across the distance I have – up 20 steps and about 40’ separation.

The real issue is simply getting the iPhone app to work at all.


(Alan Weaver (Beacon RCC)) #7

For whatever reason I cannot get the app to allow me to log in on my Samsung S5 phone? I have deleted the app and reinstalled it several times and still no good?  I have double and treble checked my e-mail address and password and still no joy.  Furthermore, from some of the comments on Google Play it is a common problem, is there a fix in the pipe line then please?


(Dustin Meyer) #8

I’m having the same issue as Alan. I’m also on the Galaxy S5 (Android Lollipop) and cannot log in from the mobile app. However, I can log in just fine from my computer. I have tried clearing all of my app data, restarting, etc, but haven’t had any luck yet. When I try to log in, it just says my username and/or password is invalid. I know that’s not the case since I can log in from my computer using the same credentials.


(Alan Weaver (Beacon RCC)) #9

Dustin, l have got mine sorted now. When u try to log in again, remove your previous typing an insert your e-mail again but if you look for somd unknown reason it then puts a space right at the very enx after thd last letter. So now press the back space and remove that space after the very last letter of your e-mail address. Fingers crossed if should then work?


(Dustin Meyer) #10

Thank you, Alan! That worked like a charm! I hadn’t noticed the additonal space that was being added to my username. Although, it does seem like the programming logic should have trimmed the text anyway. 


(Alan Weaver (Beacon RCC)) #11

Excellant…