User definable slow down/speed up watt zones within created workouts


(John Bytheway ZHR E) #1

I use the workout creator a lot one thing i have noticed when riding intervals i instinctively slow down or increase power based on when your warnings come on but i find they are too far away from my targeted power level, ie i set my intervals at say 260w your slow down warning could be around 300w and your speed up could be as low as 220w, thats not an actual example but its not far out.

I would like the ability to set those slow down/speed up levels, in that case ideally at +/- 10w in that case.

Secondly i really want to see in large my average watts per interval on the screen prominently, for me that is far more important than my current watts.

Thanks.

John


(Lindsay Ruppert) #2

Hi John - 

It takes a little bit of tinkering, but it is actually possible to do this. It requires you to manually edit your workout files after you’ve created them in the workout editor. I’m going to give you step by step breakdown to start the process.

  1. Create your desired workout in Zwift and save it (you’ll probably want to start this well ahead of your planned ride time), and exit Zwift

  2. Navigate to Documents/Zwift/Workouts, and find the workout you wish to edit. Click once to select the file, then right click and on Windows select Rename, or on Mac select Get Info

  3. Remove the .zwo from the end of the workout name, and replace it with .xml . Use the Enter key to save your change.

Now that the workout file is in .xml format, you will be able to edit it. Right click the file and select Edit on Windows, or Open With TextEdit on Mac to make your changes. When editing your workout file, be sure to pay attention to the format and keep your changes in line with that formatting to ensure you don’t break the file.

For normal segments, you can specify power with:

PowerLow=“0.5” PowerHigh=“0.75” 

 

That means the power zone is 50% of ftp to 75% of ftp. You can adjust this as tightly as you like. 

 

For intervals, it is:

 

PowerOnHigh=“0.5” PowerOnLow=“0.4” PowerOffHigh=“0.3” PowerOffLow=“0.2” 

 

which would give an ON-Interval of 40% to 50% and an OFF-interval of 20% to 30%.

 

So, for example, I want to adjust the ranges of my workout to keep me within 5% of my target wattage on any interval:

 

Original workout:

<workout>
<Warmup Duration=“600” PowerLow=“0.2545” PowerHigh=“0.75449997”/>
<SteadyState Duration=“300” Power=“0.81449997”/>
<IntervalsT Repeat=“4” OnDuration=“60” OffDuration=“300” OnPower=“0.75449997” OffPower=“0.50449997”/>
<Cooldown Duration=“600” PowerLow=“0.75” PowerHigh=“0.25”/>
</workout>

 

To adjust the range on the normal interval,
<SteadyState Duration=“300” Power=“0.81449997”/>
would be changed to

<SteadyState Duration=“300” PowerLow=“0.76” PowerHigh=“0.86”/>

 

To adjust the range on the over/under intervals, 

<IntervalsT Repeat=“4” OnDuration=“60” OffDuration=“300” OnPower=“0.75449997” OffPower=“0.50449997”/>

would be changed to

<IntervalsT Repeat=“4” OnDuration=“60” OffDuration=“300” PowerOnHigh=“0.7” PowerOnLow=“0.8” PowerOffHigh=“0.45” PowerOffLow=“0.55” />

 

After you finish editing your workout file, be sure to save your changes to the file. Zwift will read the files in either the .xml or .zwo format, so as long as you’ve preserved the proper formatting, the workout will appear in your Custom Workouts menu as usual.

 

As for your second suggestion, I’ve added it to our request list for consideration as we continue to expand and improve Zwift.

 

I hope all this helps! Ride on!


(John Bytheway ZHR E) #3

HI Lindsay,

Thanks for the reply and wow that is certainly a long way round to get the job done, whilst i appreciate the fix (and i will try it) hopefully you will add the option to your list as well as my second request, all it needs are 2 additional boxs when you set up your interval zone, ie watts, time, slow down, speed up, all in the set up dialogue…job done. 

Thanks again


(John Bytheway ZHR E) #4

Hi Again,

Ok i am just looking at my workout details and they don’t seem to marry up to yours so i am not sure which figures i am supposed to change, lets say i want the the slow down sign to show up at 107% FTP and the speed up sign to show up at 98% FTP which do i change.

<workout_file>
<author>J.Bytheway</author>
<name>Telekom 40’s x 15</name>
<description>15x 40sec intervals with 20 sec rest</description>
<tags>
<tag name=“INTERVALS”/>
</tags>
<workout>
<Warmup Duration=“300” PowerLow=“0.24887639” PowerHigh=“0.60468161”/>

I assume this is the section i am looking at.
<IntervalsT Repeat=“15” OnDuration=“40” OffDuration=“20” OnPower=“1.0541199” OffPower=“0.49981272”/>

The 1.05 is the top of my tempo zone and the .49 is the recovery inbetween the intervals…where are the figures for the speed up/slow down signs?

I assume this is the cooldown.
<Cooldown Duration=“600” PowerLow=“0.60256916” PowerHigh=“0.25079051”/>

</workout>
</workout_file>

Thanks in Advance.


(Lindsay Ruppert) #5

Hi John - 

You’ve got the right section there. 

You’ll want to change -

<IntervalsT Repeat=“15” OnDuration=“40” OffDuration=“20” OnPower=“1.0541199” OffPower=“0.49981272”/>

to -

<IntervalsT Repeat=“15” OnDuration=“40” OffDuration=“20” PowerOnHigh=“1.07” PowerOnLow=".98" PowerOffHigh=“0.45” PowerOffLow=“0.55” />

I haven’t adjusted the range here on the PowerOff sections (which are your rest intervals), if you want to tweak those as well, just keep in mind that the High level is top range of the interval (going over will tell you to slow down) and the Low level is the bottom range (going under will tell you to speed up). The number after the equation sign is the exact percentage of FTP it will use.

Let me know if you have any other questions!


(John Bytheway ZHR E) #6

HI Lindsay,

Sorry to keep bugging you, i tried your fix tonight and for some reason it did not work, my FTP is 267 so i expected the slow down sign to come in about 285 watts but it did not show until 304 which by my calculations is 114%. I copied and pasted your text into my file so i am a little confused, please advise.

Here is my file;

<workout_file>
<author>J.Bytheway</author>
<name>Telekom 40’s x 15</name>
<description>15x 40sec intervals with 20 sec rest</description>
<tags>
<tag name=“INTERVALS”/>
</tags>
<workout>
<Warmup Duration=“300” PowerLow=“0.24887639” PowerHigh=“0.60468161”/>
<IntervalsT Repeat=“15” OnDuration=“40” OffDuration=“20"PowerOnHigh=“1.07” PowerOnLow=”.98" PowerOffHigh=“0.45” PowerOffLow=“0.55” />
<Cooldown Duration=“600” PowerLow=“0.60256916” PowerHigh=“0.25079051”/>
</workout>
</workout_file>

Thanks.


(Lindsay Ruppert) #7

Hi John - 

I’ve verified what you’re seeing, but unfortunately I don’t have an answer for you as to why right now. There may be some kind of limit on how tightly the range can be tweaked that I am unaware of, and the developer who could tell me has left for the night. I will touch base with him after the weekend on this issue and report back once I have more information.

Ride on!


(Lindsay Ruppert) #8

Hi John -

Just a quick update - we did find a bug in the program that is preventing the range from being adjusted below a certain point. Thank you! It is being looked at, and will be addressed in a future update.

Ride on!