Upcoming Changes to Supported Operating Systems [Effective August 2022]

A bit OCD and/or pedantic :sweat_smile: but the OS X naming convention ceased at 10.11. Starting w/10.12, it has been MacOS.

1 Like

Great news, the fewer potatoes the more sauce.

7 Likes

Using mental disorders for entertainment value is rather distasteful.

1 Like

Corrected upstream and elsewhere in our comms . Thanks for the callout @Lin_Alan

1 Like

These pages may lead to some new users being disappointed in a few months. I realise there are notes at the bottom stating that support is changing in August, but IMO it may be better the other way around (put the new data in the table now and have notes saying which older versions will be supported until August).

Anyway these links may be useful resources for anyone wondering what operating system their Apple device can support:

For example on the iOS side you’ll need:
iPad 9.7" 5th Gen or newer
iPad Air 2 or newer
iPad Mini 4 or newer
Any iPad Pro model
iPhone 6S or newer
iPod Touch 7th Gen

9 Likes

If you’re running an unsupported version of macOS, and your mac is too old to support updates from Apple, all is not lost. You can use OpenCore Legacy Patcher to install a recent version of macOS still supported by Zwift (but not by Apple). If you do that, the only question is whether your hardware is fast enough to deliver the game performance you desire.

2 Likes

I know it states android 7&8, but are there any plans to integrate the zwift client to chromecast with google tv or nvidia shield? both of these are powerful devices that a lot of users have available in their homes.

1 Like

Hey all - wanted to update this thread to note that the August 2022 deprecation will affect macOS 10.14.4 and below. Zwifters using macOS 10.14.4 have been informed via email.

1 Like

Hi everyone,

We wanted to remind those using devices running these operating systems to see if it supports a more recent version of the OS.

If your hardware is not capable of running a newer OS version - you will see a greyscale version starting with the July 2022 game release1.27, which looks like this:

Starting with the August game release v 1.28, Zwift will no longer run on deprecated devices.

2 Likes

Big Sur 11.2 runs quite well on some older macs and doesn’t have the problems some later versions do.

You need a metal compatible GPU also. Open core may be needed to provide boot screens.

Monterey 12.1 and 12.2 run okay on some older Macs with Opencore. Martin Lo’s package is fairly simple to use.

Steer clear of 12.3 and 12.4 however.

On Macrumors Forums in the Mac Pro area you can find while topics on Opencore.

I’m a bit confused (sorry). My elderly MacBook Air runs Mac OS Monterey 12.4. Do I need to upgrade or not?

No. There is no upgrade for you. You’re on the latest Mac OS (Monterey) as well as the latest version (12.4).

Macs running 10.14.4 (Mojave IIRC) need to upgrade by August.

1 Like

Well that’s a crappy way to treat paying subscribers. Force us to ride in black and white with an annoying banner across the bottom of the screen. We are already aware the our devices won’t work starting Aug 1st since we’ve been required to acknowledge to open the game for the past two months. RGT is looking very tempting right now due to the way Zwift treats paying subscribers.

2 Likes

Such a bad decision, and completely unnecessary to penalize users already facing the cost of upgrading. There are many better ways to communicate this change in game. I’m fine with dropping support for old operating systems, but this is not how to do it.

3 Likes

The pace partner D Disc didn’t work for me. When I joined the pace partner, I was started at the top of the Alpe Du Zwiftwith no pace partner in sight.Would be nice if you could acknowledge the problem since I’ve reported two other issues previously without even a reply or acknowledgement.

Is there a way to tell whether our device will be deprecated for the companion app? I run the companion app on an old Kindle Fire and can’t figure out how to tell the OS version since it’s not a straight up version of Android OS. Probably should have asked BEFORE prime day rather than right after, but I forgot until I saw this announcement.

@Paul_Himes
Amazon has this page to identify your Fire tablet and which Android version it runs

Thanks so much. Looks like mine is still running Android 5.1 (!).

Guess I need to find a new device. Don’t have a cell phone because, as a college instructor, not having a cell phone is the only way to keep my work/life balance (and my sanity) without students calling me at all hours. Not sure what to go with.

1 Like

A used cell phone with cellular service turned off or SIM card removed would work. Don’t log it in to any accounts except for Zwift, or use a new account unknown to work contacts.

1 Like