Unable to steer using phone on handlebars

I can’t get the phone steering to work. I run Zwift on my laptop on the same wifi net as the Companion app on my IPhone Xs. They are working together properly. After joining the MTB track, it says that I should centre my handlebars and press Start. I do this and I start cycling down the track but the steering doesn’t work. I’ve tried holding the phone and turning it in all sorts of ways rather than have it on the handlebars, but nothing I try seems to work. If I press a button on the Companion app on my phone, Zwift on my laptop reacts and vice-versa, so my setup seems good. Can anyone help?

I posted the same problem during the week.
It appears to be a bug as my friends are also having the same problem.
I tried various phones, tablets, Apple tv and nothing worked for me.


Thanks. Sorry that I didn’t see your post. I’m looking forward to the fun of it, so hopefully something will be sorted soon.
Kizzie The Pig!

I have the same bug. Or is it a feature?

Hey Guys…
Brand new Zwifter here… Having the same issue and struggling to find any answers to resolve the issue. I run Zwift on a Windows 10 laptop and use a Google Pixel 3XL to run the companion app, I have the phone mounted to the bike temporarily using a car smartphone holder fixed to a reflector bracket which works fine for now but will look at something more permanent like the Quadlock system maybe in the future.
The companion app and the PC are on the same wifi network and the app seems to function in every other aspect other than the fact I have no steering. It’s frustrating for sure as I really wanted to ride Repack Ridge!!! :frowning:


1 Like

Same issue…I tried steering on repack ridge and it didn’t work for me…. Jetblack turn block,iPhone X mounted in centre of bars with quad lock, ZC app connected via wifi. trainer connected via Bluetooth. Using Apple TV 4K to run zwift… steering did not work at all…

Disappointed as a mtber was looking forward to some kind of single track fix while in lockdown.

Hopefully zwift can sort this out ASAP.


this is the title on the zwift forum (about-the-steering-category/265483?u)
Apparently I’m to new at this to be able to include links in my posts so you will just have to search this topic and hopefully you find the page I found if you want to follow this up for yourself?!

It looks like you need to reach level 12 before the steering is enabled.

So I just stumbled across this post, still researching it to try and confirm as I can’t seem to find any info on zwioft’s website and it doesn’t appear to be stated anywhere either. I even contacted zwift asking about the steering and wasn’t informed of this.
I’m going to keep digging to see what else I can find and hopefully in the meantime someone who is a bit more experienced than a level 2 beginner can confirm this is the case for us newbies?


Hi, i have been using the companion app steering on repack ridge since they released it without any issues so I know how it should work. However I have the same problem as you and the others that have replied here. It no longer works. It seems to have stopped working since a recent update so I think it is a bug/zwift issue. I have sent a couple emails to support but they never respond… in fact in the 3 years I have been using zwift I have not had a single reply to any of my support emails. Has anybody ever had a response from zwift support?


Hi Guys, so glad I found that I am not the only one with this annoying issue! Was so looking forward to hitting some trails. Started from Tempus Fugit, entered the trail no joy, swapped phones, no joy, Restarted the ride with Muir and Mountain still no joy. I hope the guys at Zwift hasn’t forgotten about us Companion drivers seeing that they are developing driving for more advanced devices now. I truly hope they sort out this issue.

Hi Daniel,
I asked the support team a question about using a setting to mathematically alter my gears rather than me having to buy a bigger front cog as I’m using a mountain bike. They did respond fairly promptly and so did Wahoo about the same thing. I’ll try my luck again with this one.
By the way, the reason I asked was that on the road I run out of gears using a mountain bike. So I managed to squeeze a 38 tooth front cog onto my Norco FS1 instead of its normal 30 tooth but I had to put a washer in where it shouldn’t be. Anyway, ERG mode means they should be able to alter the ratios so I could pretend I have, say, a 42 tooth front cog. They said a number of people have asked for it but it isn’t on the radar just yet.

I’m using Zwift with Apple TV and the companion app on an iPhone for steering. I was hoping that during post surgery recovery to ride repack ridge as its worked great in the past. Steering now has so much lag that it’s unusable. I see that the steering sensitivity setting was removed in a past update. Very disappointed that steering is not working!

Last year I had purchased an Elite Sterzo smart steering riser but found it didn’t work well. I took it out of storage, updated the firmware on it to latest version and found that it worked really well on Repack Ridge!

Hi, you can change the gearing ratios in zwift via Settings → Trainer difficulty… i thought this would have the same effect so you wouldn’t need to swap chainrings?

Has steering worked for anyone on repack ridge yet or is it just me? I am talking about using the companion app, not a steering device. Steering using the companion app only works on repack ridge… not anywhere else in zwift. I have been trying after every zwift update but still no good. I really miss riding repack ridge! I have logged three support calls over the last three months (one every four weeks)… the first I was asked to clarify what I meant, then no response after 4 weeks (actually still no response to date), the second I got a response “hinting” it was a known issue but then they did not respond to my reply. The last one I was asked to clarify what I meant by steering isn’t working on repack ridge, and again no response. What the is wrong with zwift support to make paying customers feel like they are talking to a brick wall! I just want some sort of answer :frowning:

Nothing to add, other than i have the same problem. Anyone heard back from support about this?

Hi there,
I’ve only been there for a week now. I have the same problem. Still in the process of delving into the secrets of Zwift, I wasn’t sure if I was doing anything wrong. All functions via the coupled Comanion app work, only the steering does not. Hopefully there will be an update soon that fixes this bug.

Steering using a phone was set up as a “Futureworks” feature, (effectively Zwift’s way of saying it’s “in Beta”) and I believe they stopped developing it because they couldn’t find a way for phones to give people a good enough, consistent enough experience. So it wouldn’t surprise me if this feature had stopped working on some devices.

If it doesn’t work for you, you’re not missing much. I tried it about 18 months ago; it was fun and I got it working ok but I didn’t feel it was worth the hassle and I didn’t try it again until last week, when I got a Sterzo.

I’m only mildly curious about steering. I’m actually more interested in riding the single track that requires it.

As others have stated Steering is a Futureworks projects as such there is not commitment to it and some might argue ( who have invested several times in product to help with these test projects) being so classified ensures that it has no Future as I have yet to see anything progress to an active and properly supported feature , Steering in particular seemed to come up with endless latest new things and discard everything from before , endlessly asking for feedback but never sharing back anything from that . It was the most disappointing and disengaged beta experience and no surprise interest never takes off .

To be honest I dont even know if there is still such a thing as Futureworks team still running at all in Zwift its become that unimpressive.

Ok, so I finally had a response from Zwift… their response was that they are aware that steering on repack ridge isn’t working and advise it will be fixed in a future update. Seems like a pretty standard response but now finding out from a couple others here that it is an unsupported project makes me wonder whether it will ever be fixed. I was not aware that it was a “Futureworks” project.

Strange thing is if you look on Strava you can see people still completing the route successfully… so maybe its only not working for some… ios vs android? or maybe only working for people with a proper steering device.

I am really dissapointed… I actually really loved it and it worked perfectly for me and was looking forward to more MTB routes like this. In fact it is one of the reasons I would keep my zwift subscription going over summer. I really don’t use zwift during summer… just too hot inside (even with fans) and I just ride MTB outside in real life… but if I couldn’t make an outdoor ride or the weather was bad I would look forward to doing a quick ride up to repack ridge and do a lap or two.

I just don’t understand why Zwift do not inform their customers of issues like this… if they are completely aware of the issue why not let people know… just be honest so we don’t have to send several emails to support and wait months just to be told “its a known problem but we may or may not ever fix it”. Even worse what about all the people trying it for the first time, or who have used it successfully before like me, who go to repack ridge and stuff around wasting their time thinking there is something wrong with their hardware or companion app trying to get it to work. ffs.

1 Like