Unable to login with correct credentials

Similar to many, many other posts describing inability to login with correct password. Yet I can login to the website, this forum etc. When I press new user and enter usual login info it works. Close and reopen the app and doesn’t work again. I just activated Zwift again instead of Rouvy. If this doesn’t work soon I’ll ask for a refund and switch. I don’t understand why errors like this haven’t been resolved at this point. Very frustrating.

Hi Brad,

There’s a couple of possible fixes for game login problems.

  1. You don’t say if you have, but have you tried resetting your in-game password? Changing the password on both the server end and your end can clear up this issue, and is the first step I’d recommend.

  2. " When I press new user and enter usual login info it works" This is an interesting clue that’s come across our radar in the past. When you registered your in-game username, did you fill both of the name fields? That is to say - the FirstName and LastName fields must have at least one character. Here’s the important part: a space does not count as a character for Zwift purposes. Assuming you did - at some point later, did you change these name fields to something else?

  3. I see you’re running the Zwift game app on a Widows computer. The Zwift game app piggybacks on the default browser of whatever browser is built in to that OS. For Windows machines, that’s Internet Explorer. Please try purging the cache of IE, even if you normally use a different web browser for web surfing or have a different browser set as your default.

First, make sure that you’ve exited Zwift and it’s no longer running in your Windows system tray or on your computer. Make sure to right click on the Zwift icon here (if present) and choose exit. If no icon is located here, that means that Zwift isn’t currently running on your Windows computer.

To clear Internet Explorer:

  1. Open your Start Menu type ‘Internet Explorer’ and tap the ‘Enter’ key on your keyboard or left click ‘Internet Explorer’ when you see it come up in the search.

  2. Click the settings cog wheel in the upper right corner of the browser, put your mouse cursor over ‘Safety’, then click ‘Delete Browsing History’. You can also get here directly by pressing and holding Ctrl and Shift, then with those two buttons held down, tap delete.

  3. Check ‘Temporary Internet Files and Website Files’.

  4. Check ‘Cookies and Website Data’

  5. Check ‘History’.

  6. (Optionally, you can choose to ‘Preserve Favorites Website Data’ if you commonly use Internet Explorer to browse the internet.

  7. Finally, tap the Delete button. (You should see a confirmation at the bottom of the screen that says, “Internet Explorer has finished deleting the selected browsing history”.)

  8. Close Internet Explorer.

  9. The last step is to purge your game app’s cache. To do this, open Windows Explorer (aka "My Computer) to see the files on your computer’s hard drive.

a. Navigate to the Documents folder that Windows creates in ​this file path: C:\Users\YOUR_NAME\Documents\Zwift
It looks like this:

b. Delete the prefs.xml file, which is your in-game cache file. This will nuke some of your in-game settings like music volume, graphics settings, but your account details will not be affected because that’s stored elsewhere.

c. When you launch the game again, a new prefs.xml file will be created. You will have to reset any customized settings that you nuked, but these should be quick and easy.

Would you go through those three measures in order and let us know if that cleared up your login problem? If not, we have some other steps we can take, but let’s try these first. I hope this helped!

Hi there.

  1. Have tried this before. Just tried again - still not working.
  2. This WAS working earlier but doesn’t seem to be any longer. I’ve filled in first and last name fields with names. It’s possible I changed the names at some point as sometimes I use my real first and last name and occasionally a “pseudonym”. Can’t definitively say in this case if I’ve changed it at some point.
  1. Followed your steps. Exited Zwift and cleared all 3 browser caches (IE, Chrome, Edge) and deleted the prefs.xml file.

Interestingly, earlier this evening I opened Zwift on this Win10 laptop and it finally logged in successfully. However, that only worked once. I’ve probably tried about 15 times today and 14 times it failed. I did a workout earlier this evening on another Win7 laptop I have and that worked fine as always. I wanted to move to this laptop for the direct BLE (no Companion app in the middle required) and because it is newer.

Thankfully it still works on my old laptop, but I would really like to get this resolved if possible. I know others are having the issue, so would really like to help figure this out.

Thanks for the helpful message, looking forward to next steps!

Meant to add that for 3) that didn’t resolve the problem either.

Just tried again with 2) from above and it logged in. Closed Zwift and tried again and it wouldn’t. Seems to be random. Bizarre.

Interesting that the Win10 laptop causes issues and the Win7 one does not. Have you always had problems on the Win10 machine, or did they crop up recently? It’s possible that Windows patches can cause problems, and our QA team might want details by looking at the log files from your machine.

You strike me as highly tech capable, so this next set of steps should be simple for you.

Step 4. On the problematic Win10 laptop, save the aforementioned log files. These contain data that tells us about your laptop configuration, the launcher application logs and the game application logs. In Windows Explorer, copy the entire Logs folder located in Documents\Zwift to your desktop.

You’re not going to do anything with those log files yet - you’re just saving that folder someplace where they won’t get zapped in the next step.

Step 5a. Manually delete the game’s application folder. That’s in C:\Program Files (x86)\Zwift

Go ahead and nuke the entire Zwift folder.

5b. Please download the latest Windows app from zwift.com/download and install it.

Did the uninstall / reinstall solve your issue? If no, that’s when we’ll want to see those log files.

Step 6: Write in to support@zwift.com and attach all the log files (please compress into a ZIP archive to save space).

Thanks - only started trying to use the Win10 machine for Zwift - previously always used the Win7 device. Have uninstalled a few times previously and nuked all Zwift folders but didn’t work. I’ll attach the log files tonight/tomorrow. Thanks again for the assistance.


En el transcuro de esta semana pasada instale zwift y me ha ocurrido algo parecido al problema comentado.
Durante la descarga y al iniciar sesión me aparecen diferentes errores de script (adjunto fotos) y después de pinchar en la “X” y quitarlos de la pantalla, introduzco mi email y contraseña para acceder, al entrar veo diferentes pantallas con imágenes de zwift pero a los segundos se cierra el programa.
Mi portatil tiene windows 8 y reúne los requisitos que se solicitan, tengo Internet Explorer 10, aunque suelo utilizar Chrome o Edge, y he probado con las diferentes opciones que se han planteado en los foros y no me han dado resultado.

Al hilo de lo que comentas de eliminar en C:\Users\YOUR_NAME\Documents\Zwift el documento “prefs.xml” en mi caso me aparece como “prefs.xml.INVALID”

No se que más puedo hacer, la verdad que es frustrante después de haber instalado y desinstalado el programa 7 - 8 veces.

Les agradecería su apoyo y asistencia


Un saludo

Continuing the discussion from Unable to login with correct credentials:

Hola si lo resolviste me ayudarias como hiciste? saludos

Trying this Win 10 device again as my Win7 laptop has been having problems when Zwift is very busy (27k riders this morning). I don’t know if that’s a problem with my device or Zwift problem with so many riders in Watopia, as it has happened before when so busy. Regardless, separate problem.

My issue is not being able to login via this device (sometimes). Tried all the steps you listed again. No luck. Same as before - seems random and bizarre. Sent my log files to Zwift support a moment ago.

Are you being prompted for a username / password, or does the game store them and start you off on the “Let’s Go” button instead?

A common error is an added extra space in the username. On some OS platforms (I’m told this happens more on iOS), hitting the tab key to move from the username field to the password field adds an extra space at the end of the username. Are you by any change getting to the password field by tabbing your way there?

I click the Let’s Go button and it seemingly starts to load. However, then you hit the “Logging in” screen and this is where it fails and prompts for a username and password (that don’t work). The times when it works properly, you sail right through after clicking “Let’s Go” without having to enter anything.

Has the Win10 machine has worked well in the past, or is this the first time this computer’s been used for Zwift?

FWIW, I patched yesterday’s game update this morning. It fired up just fine. Early this afternoon, after we released a hotpatch, I used the launcher app to update the game app again, and it hung up.

Dumb as it sounds, rebooting my Windows laptop cleared this up. Would you try that and see if it makes a difference?

See our previous discussion above from November. I’ve tried to use it but it’s too sporadic (logging in). Interestingly, I just logged in successfully from it after about 15 unsuccessful tries. Like I said, sporadic.

Sorry, forgot to answer one of your previous questions. I don’t tab between the fields, I click between them. So that shouldn’t be an issue.

This is a real stumper. If you’ve gone through all the stuff we’ve talked about upstream, there’s no reason it shouldn’t work.

Have you tried the password reset option? Nuking the password from this side is an option we can try if you want to.

A post was merged into an existing topic: Not able to log into account