Turn off Bluetooth scanning in game when no BT devices are used

Problem: Scanning for Bluetooth devices in the game causes drops of Bluetooth connectivity such as earphones in the game.

Suggestion: Turn off Bluetooth scanning when in the game, if the user has no Bluetooth devices paired. Such scanning does not make sense in such scenario.

Jakob,

We only scan for BLE devices at the pairing screen. And then we only re-initiate scanning if a sensor that was paired dropped.

What makes you believe we are continuing to scan in the game?

//Jordan

Zwift Game Design

Hi Jordan,

See response I got from Zwift in support ticket #94258:

“At this time we have no way to turn off the Zwift game scanning for devices. You can post it as a feature request in our Knowledge Base if you would like.”

–Jakob

Jakob,

I think they may have misunderstood what you were asking. If bluetooth is turned on for your computer, we cannot not scan at the pairing screen. That does not, however, mean that we continue to scan once you start riding.

Does that make sense?

Ride On,

Jordan

Hi Jordan,

That’s good news. From that, I assume that the issue that Zwift operations, during riding, is causing drop of Bluetooth headphones (despite no existing Zwift device Bluetooth pairing) should be referred back to the support ticket.

–Jakob

Jakob,

I discussed the issue within the Game team with the programmer who handles BLE connectivity. He cannot imagine any way in which what we are doing would affect your headphones. Perhaps the headphones are overly sensitive to interference from other devices that are transmitting on the BLE frequency? But he can’t imagine any way in which our code would be causing problems.

The fact that - I’m guessing - it happens only when you are riding on Zwift makes me think it is more likely an issue with the headphones struggling with the other BLE devices, not with Zwift.

//Jordan

Thank you for checking, Jordan!

The Bose QC35 II have no issues at any other time than when Zwift riding is starting so it is a mystery so far.

Regards,

Jakob

1 Like

Same issue here, I use ant+ for connectivity but as soon as I open zwift my computer starts to repeatedly connect and disconnect to my bluetooth speaker.

This is extremely annoying.

1 Like

Same problem here and actually I’m a little bit pissed (maybe I should not write this immediately after the problem appeared and ruined a training session).

I’m using ANT+ to connect my trainer and a heartrate-belt. Everything works fine - as long as I don’t start using my BLE-Headphones during the training.

  1. After about 35-50 minutes of the ride Zwift drops the ANT+ connection to my trainer. The first time this appeared, the connection was re-established a fews seconds later. Today, the connection was lost totally and didn’t come back. I had to restart Zwift.

  2. My BLE Headphoes are disconnected from time to time from my Macbook while I’m using swift. Annoying OSX error messages appear which say, that OSX can’t establish a connection to my headphones. It’s a funny connected-diconnected-loop. No need to mention that the BLE-connection to the Headphone is stable if I don’t use Zwift.

  3. If I disable Bluetooth on OSX the ANT+ connection is extremely stable.

So actually I can’t do long workouts with zwift using my BLE headphones. And yes: Zwift must do something on the Bluetooth-channels during a ride, even without any connected devices. Your developer is invited to come on over to my flat and watch the problem appearing after about half an hour of riding.

Please let us disable the usage of BLE inside Zwift completely. I’m talking about a switch called “disable Bluetooth”. If I activate this switch, Zwift should not touch the Bluetooth of OSX in any kind. No searching for devices, no interaction with OSX. Nothing. This would allow OSX to commiunicate with the headset and Zwift might not get in trouble wit hthe ANT+ connection.

Or: insert a XLM String inside your settings to disable BLE. I would be able to modify this file…

But guys: give us a solution for that problem. Doing >1h rides withoud using a BLE Headphone for listening to music is horrible!

Regards,
Philipp (now using fitfiletools to merge the two workouts which should be one if Zwift didn’t had problems with BLE Headphones :wink:

1 Like

Philipp,

I went through this again with our lead programmer on the connectivity side. There’s just nothing we are doing here. Once we stop the initial scan, we literally do exactly as you say - we do not touch Bluetooth in any way.

Now, that doesn’t mean that interference doesn’t happen. ANT+ signals - or the BLE and/or ANT signal from your trainer or powermeter - can certainly cause interference. But it’s just not anything we are doing.

This is not to say that your problem isn’t real. I am sure it is. But the interference between ANT/BLE devices - along with the various wireless devices in your home - is just not something we have control over.

We test specifically for this - and there’s no sign from our QA team that the software is doing anything other than what it is supposed to be doing. So I can assure that it’s nothing we are actively doing with BLE, because we just don’t do anything with BLE except when pairing. And if you don’t pair a BLE sensor, we never again use BLE.

As a reference, I run my BLE headphones to my Mac where I do most of my work. But I typically ride Zwift on a PC gamin laptop. And I get dropouts regularly on my headphones - even though the headphones are connected to an entirely separate computer. And the computer - a PC - that Zwift is running on doesn’t even have BLE on it.

And people wonder why there was outrage about getting rid of the headphone jack on phones…

//Jordan

Your example of customer outrage is completely unrelated, not to mention condescending.

Phi’s issue also doesn’t sound like the same issue this thread is about.

Fjolnir,

Humor obviously doesn’t always translate. I certainly did not mean any sort of condescension. My point was simply that wired headphones don’t have these issues and that in spite of being “old-fashioned,” it wasn’t (and isn’t) necessarily a worse system. Anything wireless is always going to be more sensitive to any sort of EMF. The most reliable headphones I have are a basic pair of wired headphones attached to a 5-year-old iPod Nano. And that’s what I use most often still for listening to music - and not just when I Zwift - because it just works.

We are extremely sensitive to the impact of EMF, because more often than not, it’s interference that is causing trainer dropouts or powermeter dropouts that are affecting Zwift.

When you have a bunch of wireless devices all transmitting across a relatively narrow spectrum of frequencies, interference is inevitable. We can test our code to make sure we aren’t unnecessarily adding to that interference by accessing BLE when it’s not needed, but we cannot test every combination of headphone/trainer/heart rate strap/powermeter/etc. And even if we could test them, we couldn’t actually do anything about it.

Unfortunately, this is just not a problem I can solve. The initial thread was “stop scanning on BLE.” And I was able to confirm that is exactly what we do already. We only access BLE during the initial pairing process and unless you connect a BLE sensor, we never again touch it. The fact that BLE dropouts happen because of EMF while riding Zwift is not because of anything we are doing; it’s just because of all the wireless devices in close proximity actively broadcasting and receiving at the exact same time.

I wish that I could fix this. But unfortunately wireless interference is a problem of physics, not of Zwift.

//Jordan

I decided to post in here, Fjölnir, 'cause the initial request of Jakob was about disabeling BT scanning as we all think that this might cause prolems with connetion drops as soon BT-headphoes are involved. My thought was that the ANT+ problem I get if I use my headphones might just be a follow up problem of some kind of “device-searching-trouble” inside Zwift.

For the moment I accept Jordan’s response saying that Zwift doesn’t do any things after pairing and I will do some investigations on that point. Maybe my problem is caused by the fact that my Tacx ist speaking ANT+ and BT. I can imagine that the Mac tries to pair it via BT as soon the ANT connection is lost. 

I’m with Jordan that there might be a lot of interferences within the used frequencies (ANT+, BT and WLAN are using the 2,4GHz band) but disabling everything apart from the ANT+ devises would be a lot of work.

What I will try is: disable BT on the Macbook during the start of Zwift. I will re-enable it as soon I’ve started my workout, when my devices have been paired via ANT+. Let’s see if this will change something.

 

@Jordan: I like your kind of humor ;-). But you forgot about two things: 

  1. Apple decided that wires for headphones are some kind of deprecated. As everyone knows: Apple’s always right so we don’t need any disussion on that point. They and us know: audio quality is overrated  ;-)
  2. Since everyone uses BT headsets, the strangle-rate of people doing sports has dramatically fallen. BT headphones are a lifesaver. :wink:

Jordan,

While I understand and agree that EMF may in many or most instances be the issue, can I be sure that, if I pair a BLE device, then change my mind and try to unpair it in Zwift, that it’s completely eliminated from the configuration?

When I initially brought this up, my impression from the behavior of the Zwift pairing screen was that, despite having tried to remove my regrettable BLE pairing and rely solely on ANT+, Zwift still had some recollection of the BLE pairing that, in this instance, meant that Zwift did not only talk ANT+, but due to the previous BLE pairing also would not stop talking BLE, hence aggravating the issue of interference.

Regards,

Jakob