Turn commands flaky when using Zwift Companion [July 2022] [3.37.0]

I can no longer make U turns or left and right turns with the Zwift phone App???

First time messing w/manual turns in a long time when I discovered they don’t work!

Apple TV 4K
Latest iOS Companion app on latest iOS

While I could u-turn all day long, I could not get the directional arrows to work/respond!!

any update on this?

I don’t know where Dean got his info from, but 3.38 allegedly fixes this and the decimel point weight bug, among other things.

I’ll check this out and see if it fixes the problem

I’d make sure you check the last line of those supposed release notes!


Turning / u-turning appears to be working:
Running the companion on a Android 10 device (tab a8) on .38 of the companion, I had no problem with performing u-turns or selecting directions using the companion app.
I was on Richmond and had a few occasions where mashing the “right” direction was required to select the reverse climbs direction (approaching the start/finish straight, broad street junction from the direction of the reverse climbing loop) as there appear to be 3 directions available (for 2 roads, which is something I’d never noticed before).

Edit 2: Just to say I had what can only be described as “expected” behaviour on a second set of tests; I was able to select a direction, have the game reflect that choice and take that direction. I was also able to chose a direction, and switch back to my original choice and have the game to the correct way.

Edit 3: Another ride today - this time on France, companion running on another device (android 9 moto z3) after I finished the race, I pulled a u-turn (took 2 attempts), and had the issue where I couldn’t change a direction choice once I’d selected one. So guess I got lucky on Richmond yesterday!

still says pizza slices too.

Yeah sorry folks, bored kiwi that didn’t leave the sarc flag on that post.

When you say you were able to make turns, were you able to select straight ahead? either as a change of direction or if you changed off course and then tried to go back to heading straight on?

I am able to choose left or right but not straight ahead.

The one time I was able to get it to work (on Richmond) I was able to select straight ahead as an option (on the junction that gave you a left turn into broad Street reverse sprint, straight on to the main loop - I think- and right to the reverse climbs). I was also able to select left/right (and keep switching) on the reverse fan flats junction to the main loop. Unfortunately I’ve been a bit tied up with group ride participation the last few days, so haven’t tried any more testing.

That’s interesting.

I am able to select left and right but not straight on. This is consistent on all worlds I’ve tried and different PCs.

I’m running the game on windows 10 and companion app on android (updated to the latest version)

By now the behaviour is pretty established, I just hope that we get some update from the Zwift dev team soon on this as it’s been a few weeks since the updates landed.


I’m hoping it’ll be one of those things that magically resolves itself with the next update

I’m nothing if not willing to subject myself to endless monotony for little-to-no-gain. I did a couple of gentle rides tonight solely concerned with poking about with this and yeah, I can only echo what you say (and also found out why Richmond “worked” for me that one time).

Left/Right at a junction - working as intended - can select either left/right on the companion app and have that work.
(Left/Straight on) or (Straight on/Right) - broken - can select only the left/right option, with straight on not being selected in game if you press it on the CA (hitting left/right arrows on a keyboard works).

Richmond. Specifically this junction here:

will provide you with 2 buttons on the companion app (which two depends on what the current selected direction is)

As “expected”, clicking the “straight on” arrow won’t select the “Main Loop” option; but pressing the Right arrow in the CA will select that route along with changing the buttons on the CA to reflect the available choices here (another press of right on the CA will then select “Reverse Climbs” - doing the reverse at this point also works, with pressing left selecting “Main Loop” and then “Reverse Loop”):

Appreciate this doesn’t add anything of value that hasn’t already been mentioned, but I thought I should get to the bottom of why I appeared to have a working setup when no-one else was (short answer, I won’t do testing in the midst of a VO2 MAX session again; evidently, thorough methodologies were lacking!)


This might be something I can use to make these turns work.
Need to check if that’s possible but I need to constrain it to a specific Zwift version because I think it’ll break “normal” behaviour otherwise

I’m not sure it works unless there are all three turns available. I have tried pressing left a number of times to see if it’ll go straight on when the options are just left or straight ahead and it doesn’t do anything.
Not something I’ve tested a lot though so might be worth looking into

Oddly I was able to make both left and right turns today w/the Companion :man_shrugging:

Maybe something was fixed server side?

left and right are fine, straight ahead doesn’t work

so if you are already going left or right you can’t select straight ahead.

I’ve just pushed out release of Road Captain that has a fix for this problem.

Tested a few routes in-game and they now work fine, even with go straight turns in them.

So, good news, Road Captain works as expected again :tada:


How did you manage to fix it and is it possible to do it manually using the companion app?