Trouble getting accurate Watts


First off I have gone on Swift and got my FTP with no problem

today I tried to do the CTS group ride and the wattage was all over the map.

It would come in really low no matter how hard that I pedalled (Big ring front, small back.), then all of a sudden jump up then fall back down again.

This CTS ride is open to all riders and they match wattage to keep everyone together.

Any input would be very much appreciated

Need more information. Trainer make and model. Connected by ANT+ or Bluetooth.

Did the workout include high or low cadence intervals? Smart trainers can struggle with these. Short 10 second or so sprint intervals they can struggle with as well.

Do you have 3 second power smoothing enabled or do you have power set to instant in the settings?

Hi Nigel

Thanks for your input.

I have a Wahoo Kickr power trainer. I adjusted the settings to instant this morning and tried doing the CTS group ride again.

Once again my watts fell right off at the beginning of the ride. The rest of the pack left me behind.

I then quit that program and picked another structured workout The Wringer which is not a group ride but still dictates the wattage output. This worked no problem.

I then was wondering if the CTS workout is a closed group somehow?


If it was a closed group you wouldn’t have been able to join the workout.

Time for a support ticket with Zwift. Something is not right.

Hi Nigel

Thanks for the advice. Zwift told me to check with Wahoo. I ended up updating  from their app & it has worked 

Thanks Again