TrainingPeaks Plans not synchronizing

Hey all,

I’ve started using Zwift two weeks ago with my treadmill, I’m currently in my trial phase and got really addicted to Zwift but have one major issue. I’ve finished one of the Zwift basic running plans which was working fine and bought a new training plan on trainingpeaks which has only structured workouts and should be ready for zwift.
From the documentation site, the workout for the same day should be visible on the workout page, but nothing appears for me. I’ve searched for solutions in this forum, renamed the workout, moved workouts to the current day and back, switched from distance to hr based and so on, I’ve updated Zwift on all devices, reconnected, restarted… but my TP Workouts do not appear.

Any other idea? I

Thanks in advance!



→ Short Update: I’ve also added a 100% power based plan on trainingspeak, still nothing new. I’ve tried to add a plan from todays plan which instantly worked

Hey @Tobias_Jend! Welcome to the forums, my friend :blush:

What are the workouts based on? Duration/distance/pace, etc. Zwift only imports certain types of workouts from TrainingPeaks - distance/duration and % threshold pace.

1 Like

Hey @Shayne-Gaffney,

you saved my evening :smiley: Seems like its already the solution after 3 hours of trying. I’ve read in another thread that the workouts have to be power based, so I was using power based workouts or tried adding distance to them.
Just imported a plan with just distance based workouts and the workouts are finally synchronized with Zwift.

Thank you!

1 Like