Tacx Vortex problems


(S weaty Sock) #1

Hi,

I am having issues with my Tacx Vortex. When I switch it on the light continuously flashes red / green. There is also no resistance control. I have been in touch with Tacx and they claim they have never seen this problem before! Not happy with their customer support, feels like to hey are washing their hands of me! Think the brake unit has packed in, anyone else had this problem?

Thanks,

Paul


(Erki Parik) #2

Hi 

I am also missing resistance control lately on my Vortex (set it up again about a month ago, worked fine the previous winter). Haven’t been in touch with Tacx yet, figured it might be an issue with the Zwift iPad app, but as others are having the same problems I’m thinking it might be the trainer. 

Erki

 

 


(Richard Smith) #3

I have Tacx Flux and for some reason the power just shoots up to 2000w every time I try and start a ride?? Have submitted a help ticket but am pretty sure it is a zwift issue as it worked fine a week or two ago, and when I logged in there was another update so no doubt this has caused issues!?!?


(S weaty Sock) #4

Erki,

 

Good luck with Tacx customer support! Has really put me off Tacx products now. I can’t remember supplier i bought the unit from so not sure how to get it sent for repairs, probably ask a local supplier in my area if they can help.

If it is what i think is wrong the part costs half the cost of a new one! Thinking about investing in a Wahoo Kickr instead


(Nicole Mackay ZF18) #5

I too have been having a problem with my Vortex I picked up second hand and has flash red/green ever since.  Initially it still worked though but now no resistance and erg mode doesn’t work on workouts.  Anyone fixed the problem?