Tacx Vortex flashing green and read

Hi
After updating my vortex to the newest version of the software the little light starts flashing red and green, and I lost control over the resistance, also in the utility app the “under” icon is highlighted red
The trainer was calibrated correctly after te update
And I just find out that the highlighted in red icon in utility app indicate voltage error

Hi Kamil, having exactly the same problem with my Tacx Flow. Have you managed to fix the problem? Thanks.

Hi Keith
Still talking to the garmin support
It’s basically one message a day and nothing seams to work
Was your one ok before the firmware update ?
As my one start having issues immediately after the update ?

Hi Kamil, flashing red and green before updating to the latest firmware. I’ve raised a ticket with Garmin but no reply as yet - I don’t hold out much hope to be honest. What have they suggested to you?

Hi! Exactly the same problem as described by Kamil and Keith, but a Tacx Flow. After the update I see the “Under Voltage” signal in the Tacx Utility app, and there is no resistance control. I also submitted a ticket to Garmin…

I was looking for doing a firmware rollback, someone knows how to do it? I found a forum for doing a rollback in a Tacx Neo using the Tacx Utility App (https://tacxfaqx.com/knowledge-base/neo-2-firmware-0-0-18-rollback/)… something similar for the Vortex/Flow?

I had a reply from Garmin suggesting that the trainer is not getting enough power to operate normally and that sometimes this is a problem when using a power strip or extension cord with the trainer, or if the power cord is not inserted fully.

I replied to say this is not the case - not heard back since.

@Keith_Landers_1402

Have you tried to move the trainer to a different room and try a different outlet that is on a different circuit

Hi Gerrie, yes tried different rooms and with/without extension lead but still the same. Thanks

1 Like

Hi Keith! The extension cords and the use of a power strip is the explanation Garmin has in the support page. But this is not my case either. I also tried different cables, power outlets, measured voltages, and all is working well except the Tacx Flow.

Hi lads sorry for taking so long to reply
So I’m talking to garmin support and to be honest I don’t think they know them selfs what’s going on
I get the same copy and paste message few times
But I’m still hoping they will come up with some solution
Surly if they were able to break my trainer with the firmware update they will be able to fix it with next one :joy::joy::joy:

Hi All, I’ve not had an update from Garmin since I replied to tell them that power/extension leads was not causing the problem. Not sure if I can expect them to suggest anything else.

All this nonsense talked about reduced power is not an answer it’s avoidance by Garmin/Tacx. The problem is in the Trainer’s hardware which they need to address and fix.

I have the problem of the Led not coming on and so far I have not got any response from the company that makes sense. They should acknowledge that there is a problem with the Vortex.

Truth to be told their hardware update is destroying trainers and they won’t take the responsibility
It’s kinda distancing, especially that I always respects garmin and thought they will have a bit better relationships with customers

Just wondering is anyone from garmin here to address those messages ?

Hi guys,

Same issue for me with my Tacx Vortex (T2180) since the firmware update (3.1.22): blinking light red and green. Today, I’ve sent an email to Garmin support, will keep you posted here.

Cheers,
Greg

Hi Greg
Hope your experience with them gonna be a bit better than mine
So far in emailing them since 1st of April ( it’s 23rd now just for ppl in the future reading that ) and all they said is that the trainer will have to be replaced at cost of €252.64
They won’t address the fact that malfunction was caused by their firmware update and they won’t even bother to check what’s wrong with the trainer as there are replacement parts available on the tacx website for way less than €252 …
also they keep deleting past messages and sending me the same copy and paste messages
Very disappointed with garmin / tacx response to this problem

1 Like

Hi Kamil,

Thanks for sharing your experience with Garmin support. Please find below mine:

  • 23/04/2020: I’ve sent an email to Garmin support via their website - got confirmation of email submission in my mailbox
  • 27/04/2020: As I got no feedback from Garmin, I’ve replied to automatic email confirmation to ask an update
  • 28/04/2020: Garmin replied but just asking me for a proof purchase and to “search for a solution here: https://support.garmin.com/en-GB/

I’ll keep you guys posted here…

Kind regards,
Greg

Hi All,

Garmin have agreed to replace my Tacx Flow after I provided proof of purchase. They will send me a replacement once they receive my faulty turbo.

Best,
Keith

Hi
is your turbo still under warranty ?
i got the same message and just after i send copy of the invoice and my address they replied saying replacement fee will be €252 (more than half price of new vortex )

hope they will replace your no problem so i can make my case a bit stronger
my turbo was month out of warranty and it was perfect before the update

Best Regards
Kamil

is that the message you received?

"Hi Kamil,
I’m afraid it looks like your Tacx trainer will need to be replaced.
If it was purchased less than 2 years ago then please return to the retailer you purchased the trainer from to discuss their returns process. If this is not possible or your trainer is more than 2 years old then we will need the following information from you:

  • Device Serial Number
  • Proof of purchase
  • Phone Number
  • Full Postal Address

Kind regards,
Br----y
Garmin Europe"

*and only after i send everything they replied…

“Hi Kamil,
That’s not a problem.
As you are outside of the two year warranty period, there will be a fixed replacement cost for this.
For this trainer, it is €252.64.
Pleas let us know how you wish to proceed.
Kind regards,
Br----y
Garmin Europe”