Tacx Vortex / firmware issues

hi guys, been using my trusty Tacx Vortex for years with Zwift and never had any issues. until today

went on, zwift picked up the turbo and then when in ride. nothing. pedalling and not picking up any cadence or watts.

i’ve done a firmware update and deleted the tacx app. any ideas? a few forums suggest it might be a firmware thing.

Anyone else had similar issues?

cheers,

Hi @Richard_Boyd

Shuji at Zwift HQ here. I see this morning’s sessions was on a Mac laptop? I see that you’ve already updated to the latest game build, so that’s good.

Have you updated the laptop’s OS since the last time you logged in with that laptop on March 8? In some cases, Catalina OS can do weird things because you have to give the game app permission to access your Locations folder. You might want to check that, although the symptoms for Locations is usually the game app won’t start.

Also try resetting the Mac’s Bluetooth module. Would you loop back and let us know if these steps helped?

Shuji, thanks for these and for replying!! oddly the next day i was able to log on an usual and completed a ride today with no issues so for the time being it looks like i’m ok. but THANK YOU for replying and ill certainly keep that down as a potential fix

Same issue, except I connected initially then lost signal multiple times. I’ve done the same as you except for deleting the app, I tried a test ride and I still lost my signal. I’ve rested the bluetooth module as mentioned and will try again tomorrow.

I’m also having Vortex problems with Zwift. Any recommendations?

resetting the bluetooth module actually worked for me. all of this happened after the Zwift update coincided with my OS update. I had to reset the BT module prior to a few rides. not ideal but it works. anyways, I’m off now for the summer. good luck.

Thanks for the reply…what ended up working for me was to uninstall/reinstall Zwift app. Have a great summer!

I cant connect any devices ie I Phone iPad and Mac and I have all the latest software and have downloaded the latest software for the Tacx Vortex trainer. I know the Bluetooth works because it works with the Tacx trainer App.

@Matt_Hall2

You need to disconnect the trainer form all other software, Bluetooth can only talk to one device at a time.

Thanks. I disconnected from the Tacx software and turned off all the Bluetooth devoices except the iPad with the Ant +dongle. Still nothing happened after I turned off everything and turned it back on. Mmm…

Are you trying to pair in the zwift app? Without paring on the Ipad.