Tacx Neo resistance

Hello, I have been using Zwift with workout mode and Tacx Neo for past 6 months or so, without facing any issues.
This morning, when I used workout mode, the resistance was quite unstable. Every 40 seconds or so, resistance increased which was not accordance with workout mode. Sudden increase in resistance hurts my knee and I am unable to continue.

The only difference today was that I used different heart rate monitor. When I faced the bug, I went back to original heart rate monitor, but the issue was not solved.

I had this same issue yesterday.

Second time that during a workout, the resistance does not increase as it should (Sprint ramp ups 16:20 todaySunday 11th). First ramp-ups worked, second did not. Tacx Neo and cabled (not WiFi)
Where should we be looking?


Hey all, this issue has been covered in this post Trainer Resistance Issues (Mainly on iOS Devices)

A fix is on the way, but in the meantime can you all try restarting Zwift and pairing your trainer but don’t pair your HRM yet? Then once you start the ride go into Menu and pair your HRM. If that makes a difference please let me know!