Tacx flux controlable not found


I have a tacx flux since 5 days, and it was working fine since yesterday. No possible to find it with the ANT on my phone and tablette, and also when i tried with the bluetooth, i have the color blue on the home trainer, but not found on the controlable section in zwift.

I checked with taxc utility, i updated the software. On TACX application the home trainer is working…

Any idea ?


I do not know your phone, but as far as i know, there is no phone which supports ANT connections.
You also have to be aware, the number of simultaneously bluetooth connections is limited. How many depends on your device and version of bluetooth stack. So you should take care that no other bluetooth devices interfer your trainer. If you have turned on your trainer for quiet a while without to connect it to e.g. Zwift, it often turns on a kind of power saving mode and you not connect anymore. In that case just turn it off and on.

Just for reference: I have a simillar issue with my Wahoo Tickr, if it is connected via bluetooth with Zwift and I walk away so that it gets disconnected, it often happends that I cannot connect it again. In this case Zwift does not recognize the Wahoo Tickr signal at all, it does not show up in the list. Even if I take out the battery and do a hard reset, it will not connect with Zwift again. Maybe your problem is a simillar one.

Erik, there are many phones supporting ANT+, my (3 yrs old) HTC U11 for example.


With a S9 you can do it (ANT+)
Also, I turn it off and on my HT and not working with ZWIFT.

What did you do with your HT to fix this issue ? Nothing ? It still not work ?

Thank for the hint.

Since i know this, i’ve been careful not to stray too far from the trainer (it only happens if the connection gets lost, the initial connection is no problem). It is always very annoying when suddenly the heart rate information for a part of the track is missing. Fortunately, that hasn’t happened to me so often. But to answer your question I have no fix for this issue yet :slightly_frowning_face: I connect my whole Zwift enviroment (Apple TV, Elite Direto and Wahoo Tickr) via bluetooth and it works very reliable.

@David_C_C, try disconnecting your trainer from the Tacx application then re-connect to Zwift

Hi, yesterday, i tried it again and worked… but i don’t know why :wink: