System fail after 45 minutes


(simon spalding SRVC) #1

For the third succesive time my ride has come to a halt after 45 mins. All sensors lose their signal and I come to a halt.

To fix I remove then rpelcae the ant which is on a usb cable near the stages.

The signal is found however as soon as I start to cycle it fails again. I did this 5 times but gave up in the end.

I ended the ride and re launcched the programme and everything was fine once again. Why does this keep happening?

I am runing windows 8.1.


(Stuart Davis) #2

Although my Zwifting is not flawless I’ve never encountered this particular issue, I regularly do 1h+ rides as do many.

I suspect the root cause may be your last sentence, recommend you upgrade to windows 10; I’m running 10 on my Surface Pro laptop without issue.


(Noel Nunkovich *USMES*) #3

I’m running Windows 10 and I’ve had this exact same thing happen 3 or 4 times. Zwift hangs for a second then all sensors drop. Remove and reinsert ANT+ dongle, go to sensors screen, software finds sensors. As soon as I leave sensor screen they all drop again. Rinse and repeat. Only solution is to kill it and start over. I’ve had it happen about 45 minutes in, I’ve had it happen 5 minutes in. Very annoying. 


(Todd Taylor) #4

OP…

Are you projecting Zwift onto a second monitor?   I have a theory that some of the lock-ups caused late in a ride are due to the graphics card puking (although this obviously depends on one’s setup).  

I had Zwift running on my laptop and setup to “duplicate” the display onto a TV via a wireless display adapter, thus having Zwift running on two screens at once.  Doing this, I’d experience the same kind of crashing you are referring to… it would crash late in the ride.   I noticed that when this happened, my laptop was just about shooting fire out of the cooling vents.

On tonight’s ride, I changed Zwift to be in “window mode” so I could drag it to my TV by using the “extend” display sharing feature instead of “duplicate”.  I had no problems after riding over an hour, so either this worked or it was just a fluke.


(Noel Nunkovich *USMES*) #5

@Todd Taylor:

My setup isn’t using a second monitor but I’m having the same issue as the OP. It doesn’t do it all the time but is happening frequently enough that I’ve gone back to using my Garmin during Zwift rides to prevent data loss.

In my case, my Zwift computer is a full tower, not a laptop, with an NVidia 750GT. Video is piped via HDMI to a 46" Samsung TV. That’s the only display.


(Alex Knol) #6

I have a similar issue running Zwift on a an older asus laptop with built in Intel graphics on Windows10. The twist is that re-inserting the USB ant+ stick (on an extension) does nothing. I have to quit Zwift and relaunch, which effectively ends my ride :-(. It happens after a while, sometimes 1:10 sometimes 0:45 sometimes shortly before 2 hours.

I will try with lower graphics setting.

*** UPDATE ***

Last night I kept the charger in the laptop and didn’t get a disconnect. I even tried 1080 resolution. The disconnects did happen towards the end of the battery life on my laptop. Unless I post another update or message, I consider this solved for my setup at least!