Stryd not working with Zwift?


(mike hennessy) #1

I just got my Stryd device…and I’m using and Apply 4K TV.

I downloaded and got the Zwift application running and it seemed to have correctly synced with the device. I started a run…and nothing…I ran on the treadmill and nothing was moving on the Zwfit screen.

After about 10 minutes…all of a sudden, it started to work, and I ran for about 30 minutes. I figured it was a one time issue and I was good going forward.

I then tried to use it today…device shows as paired…but again, as I ran, nothing was showing on Zwfit…the guy was just standing there. I tried running for 2 to 3 minutes to see if that would work…nope. I tried shaking the Stryd…not sure if it needs to be woken up…but that hasn’t worked.

It shows paired in Zwift…so it “appears” to be working…but it’s not.

Any suggestions here?? I was hoping this would be as easy as , turn on the app and start running…but it hasn’t been .


(David K) #2

Hi Mike,

Chances are your footpod is still paired with the official support app or bluetooth paired with another device. Please ensure your footpod is unpaired from the official support app, then insure the app is force-closed and that you’re not running Zwift at the same time.

Check the Bluetooth Settings on your device and if you find your footpod paired there, please unpair it. Zwift itself will handle the entire pairing process itself. I have a feeling your StridePod isn’t working because your official app is likely reading settings from it before they’re able to get to Zwift. Please let me know if that turns out not to be the case.