Steering Bug - in race (steering disabled)

Hello,

Got my Sterzo last night. I use Apple TV to run zwift so I used the companion app to connect 3 Bluetooth devices (trainer H2, heart rate, and Sterzo).

I began to warm up in free ride this morning and everything was fine. Steering worked, etc. I then joined a race (DIRT DADurday at 7am EST). When the race first started my avatar was immediately moved to the far left hand side of the road (not just lane, entire road). My avatar continued here, out of the draft, and never move back into the blob.

I quickly stopped that event and joined the next race. When I got to the pen, all the riders were missing colors. Additionally, when the race started my avatar just sat in the pen, despite the watts being produced.

I may have bugs with multiple things here - steering and maybe using the companion app as a bridge?

I have attached a picture of the start of the DADurday race, with my avatar over to the side.

—Brandon

I also experienced this bug - similar scenario - rode around free ride with steering enabled -> joined a race --> in the pen, I got the notification that steering will be disabled for this event (this actually appeared twice) --> when the counter reached 0 and the racers left the pen, I was left on the far right hand side and not able to ride in anyone else’s draft.

t’s the same experience i get and it does not matter if it is with apple tv or if it is via macbook

I quite like the sterzo as a addition to zwift.
However, I do think I found a bug with it today… after being in a group ride with it enabled, I jumped into a race that had steering disabled and for that race, I was stuck in one ‘slot’ with no draft at all. Leaving re-enabled steering, but for that race, no draft and my avatar just stayed in one area of the road.

1 Like

I had a teammate that experience this Tuesday. He had to unpair the Sterzo to get his avatar to move back into the auto-steer lane. Here’s his stream of that race: https://www.youtube.com/watch?v=Of_aRGiql3U

1 Like

I get this and I don’t even own a sterzo… Zwift broken it for everyone.

1 Like

Me too. I was in a separate lane for almost the first minute, in the 3R Turbocharged Bonus Race event yesterday.
I have never tried or owned a Sterzo, and steering was disabled for the event…
I have no idea about how many other experienced this. Did it look like that for everyone? Or was it only like that for those very few who were visible in left lane on my screen? (I think there were just two of us visible there, far away from each other)

In my case; I entered race, and same thing happened, but it was consistent in where on the course it happened. I was on London Classique course; and it put me on the far right, along the mall and back, and also the small hill… everywhere else it directed me back to the groups line. I have not experienced it before in races on watopia, although i see its happened to someone else above.

Im probably going to actually turn off the steering before entering an event from now on… Its a painful and frustrating experience

This has happened to me on off for the last month. Did two races today, first one ok, second one avatar stayed on the left & I lost the group. Zwift need to fix this quick. I don’t have a Sterzo

1 Like

What platform are you on, and is it fully up to date?

Only the most recent update suggests this bug has been fixed.

Hi yes I did the latest Zwift update last week. I am on MacBook Pro running Mojave. I’ve updated to Catalina this morning which I’m slightly wary of as I have read people have had other problems with Catalina. I will see how I get on.

Same here (W10, latest update, no Sterzo). My avatar did finally move into the draft but only when there was a sizable gap in the pack (ie. basically at the end of the pack). I quit the first race and joined another shortly afterwards, same thing.