Spin Down Calibration gets stuck

I know this topic comes and goes on here but I haven’t been able to find any solutions. My zwift calibration never completes. I have a Saris H3. Apple tv. I have tried to do the calibration on my mac and that does not work either. The calibration has not worked for a year. If it is such a common problem why does zwift continue to offer the calibration? What do other uses do? Does calibration matter?

Looks like there is a Saris Utility App. Try using that to calibrate your trainer.

Make sure that you are disconnected from Zwift and any other applications that might be talking to your H3.

1 Like

I would suggest using Saris’ mobile app to do spin down calibrations. I’ve never used Zwift’s calibration feature, always so it through my trainer manufacturer’s app.

1 Like

Same problem with my Tacx Flux 2. Get stuck on step 3 of5! ZWIFT please fix it. Thanx


Hi @Luca_Russo

Can you use your trainer software to calibrate, the calibration value get stored on the trainer so you can use the app or Zwift and get the same results.


Thank you Gerrie. But has this something to do with my trainer?

Does it get stuck with the trainer software as well?

Thank you Gerrie this was my concern. Good to know.


No, with the trainer software it works. Zwift calibration always gets stuck at step 3. I will of course use the trainer software but why does it not work on Zwift? See attaches pic. It‘s in german but you should get it :wink:


Hi @Luca_Russo

It can be that the trainer software go a change that Zwift did not yet implement yet, or the trainer update was not communicated to Zwift yet.

So always make sure all your software is up to date.

Same for me, I have a tacx smart flux s and I use and apple tv. I can easily calibrate the trainer using the Tacx utility app but I have never got the calibration test on zwift to work. It always gets stuck at step 3 as well. However, I tried to do it on my MacBook yesterday (using an ant+ dongle) and when my computer was very close to the trainer, the calibration test was working. I am still trying to find a way to fix this issue with the Apple Tv because it is very annoying. The difficulty of the trainer is completely messed up with the one from the game. Indeed, the uphill/downhill are not changing correctly the trainer’s resistance. Does anyone have an idea about how to fix it? Thanks in advance riders :slight_smile:

Hi @Selim_Gilon

This is the correct way to do it, the calibration will be saved on the trainer, so if you calibrate using the App then the trainer is calibrated.

No need to calibrate in Zwift if the trainer app work.


Okay, thank you for this information!

Then I’ll just need to figure out the issue with the apple tv

Same here getting exactly the same problem with EliteTrainner. Trainner is saying keep pedaling at current speed. If stop pedaling at 37kph and let trainer stop nothing happens.

If I use the elite app to calibrate it says stop pedaling at 33kph at let trainer spin to a stop. Which I do, then it says wait for response. But nothing happens until a long wait and it says calibration failed.

I’m so over it :frowning: Been wasting days trying to fix it, Nothing! works. Lost so much training time over this issue.

I suspect it might have something to do with incorrect instructions for metric vs imperial - can others confirm?

  • I tried several times with my Tacx Flux and indeed got stuck eternally cycling at 37 km/h.

  • twice I accelerated to ~50 km/h and then I got the instruction to spin down.

  • last time I set Zwift to imperial units. It told me to cycle at (I think - please confirm) 30 mph (=48 km/h). Worked.

So it might be as easy as accelerating to 48 km/h until Zwift fixes this bug or USA switches to metric, whichever comes first :joy:

Sorry for not remembering the exact numbers but forgot to post this right after I did it.

I am suddenly having the same issue with trying to calibrate Zwift with my Elite Suito. It gets hung up at “Keep Pedaling,” whereas it used to move quickly and naturally to “Stop Pedaling,” as soon as I hit 37kph. Any known fix?

Interesting. I will try that. Thank you for the suggestion!

It worked! The issue was the metric to imperial conversion. Thanks so much for the tip!