Sound has gone missing with Apple TV


(Kit Mitchell) #1

A bit of a weird one which I hope someone can help me with.

I Zwift using Apple TV. I’ve (as of today) slightly changed my setup in that I’m now using a different projector for Zwift than I was previously. With the new projector Zwift doesn’t seem to produce any sound. While I don’t miss that tune at the start, I’d like the rest of the sound to work.

Can anyone shed a bit of light on this for me please?

For reference, every other Apple TV app I’ve got installed is making the usual sounds they always did. Zwift appears to be the odd one out.

Additionally, the Apple TV volume bar/counter has disappeared and the + and - buttons no longer control volume. I now appear to have to do that via the projector (which has, not very good, built in sound).

I don’t know if those last two paragraphs bear any relevance but thought I’d mention them just in case.

My heartfelt thanks to anyone who can and does help.


(Vincent W.) #2

Hey Kit, have you tried completely shutting down your Apple TV then restarting it? And if that didn’t work, can you try reinstalling Zwift?

Make sure you’re on the latest version of your Apple TV as well!


(Kit Mitchell) #3

Thanks Vincent.

I tried doing as you suggested - a fresh install - and thought it had worked when the music played for a couple of seconds then (you can see where this is going)…

…nothing.

It’s really frustrating. As I said, all the other apps on Apple TV still make as much horrible noise as they ever did. Zwift is the only awkward wee beggar.

Any other suggestions?

UPDATE: Just in case anyone else has the same problem - I was able to remedy it by changing the Apple TV audio settings. It was set to ‘Best Available’ (or something of that ilk) and I had to choose ‘Stereo’, presumably because the inbuilt sound in our projector is so utterly woeful. It’s weird how all the other apps still worked but, whatever the case, at least Zwift is noisy now.


(Dirk Snoeck Henkemans) #4

Thank you for the update I had the same problem your suggestion fixed the issue for me as well.