Sensors disconnecting when changing app


(Eduardo Sugai) #1

Hi, I tried it yesterday on S7 (Exynos), A5 2017 and S9 (G9600) with a Tacx Smart Neo, could connect only using BT for now, seems ok.

The issue is that if I switch to another app like a messenger, it is disconnecting the sensors until i go to zwift again

Is that currently that way? using Strava for example allows me to record it in background.

Thanks


(Eduardo Sugai) #2

tried to play a little more today, not being able to receive data from HRM, altough it is able to connect, shows no signal over it.

also not able to use ERG mode, it shows as on, but no change on power control


(Chris Holton) #3

yeah, I had that issue as well, if you swap apps then the trainer needed pairing again


(Stephanie Lim SPR) #4

I have an S8. 

No problems connecting the Tacx Neo, but ERG mode doesn’t work.

HR strap only sometimes works. It seems to pick up no signal, however, the bluetooth HR signal can be seen via the Strava app after a bit of time. I’m guessing it takes too long to detect and the Zwift app goes into an automatic “No signal”. If I try unpair/detect multiple times eventually sometimes I get it to work (after trying 20+ times).


(Vincent W.) #5

Thanks for all the details everyone! We’ll be looking into these individual issues. For those with the ERG issues, are your resistances changing during gradients in Just Ride? 


(Stephanie Lim SPR) #6

No problems with resistance changes in Just Ride. Have just done the new update so will try again and report back.


(Stephanie Lim SPR) #7

After the new update HR pairs without issue (have only tried once) and ERG works!

I did have trouble doing a group workout event (workout targets wouldn’t show whilst in the ZA group) but it sounds like that I wasn’t the only one with that issue (general bug, not an Android bug!)


(Eduardo Sugai) #8

tried a little bit more today, ERG and HRM are ok, Smart Neo terrain simulation is working too.

Was able to keep Garmin edge logging on ANT+  on Trainer and HRM and connect them on Zwift using BT simultaneous


(Vincent W.) #9

Thanks for the updates everyone!