Screenshots on Samsung Tablet not saving

Just started running Zwift on a Samsung Galaxy Tab S6. Works great for the most part but for a couple minor issues. For one, when I try to take a screenshot, it doesn’t seem to save anywhere, either on my phone (Google Pixel 2) via the companion app or the tablet itself running Zwift. All apps are up to date and permissions allowed. Tried reinstalling the game app on my tablet and resetting permissions but no luck. Pics do upload to strava at least, but screenshots I take manually are not saved locally anywhere.

Is there a fix for this?

@Mike_Weiner
In Android OS settings have you given the Zwift app permissions to access both your camera and storage? Check that and would you let us know?

The specific path will vary depending on your version of Android and model of phone, but mine is:
Settings > General > Apps & notifications > App info > Zwift > Permissions

While you’re there - make sure Locations permissions is enabled. In Android for whatever reason, access to the Bluetooth radio is buried under the Locations service. If it’s not enabled, Zwift can’t use the Bluetooth radio.

Hi Shuji. Thanks for the suggestions. Yes those permissions are enabled. I also changed location from “while app is in use” to “all the time.” No success though. What else could I try?

Following up… anyone else have a suggestion here?

Have you tried taking a screenshot on your andriod device outside of the zwift environment?

Press power and volume down at the same time?

Good question. Yes that works.

OK…where are your images being saved to by default? Phone or micro SD?

Whatever one you have selected…switch it and give it a test.

Good idea but still no luck. On the plus side, I found my old micro SD card!
Thanks for trying though, really appreciate the suggestions. If there’s anything else you can think of, I’m all ears.