Screenshots gone

I have a similar problem. Usually you have two screenshots: One screenshot with panels (Rider data, Zwifters near you, KOM data), one without (clean). After the Dec 3 update, both screenshots are looking the same (clean).

Hi. Try this solution, seems to be working for some on Windows: Stream Deck peripheral stopped working after latest Zwift update

I have same problem - just getting the photo background and not the peripheral info when using the comapnion App - was working fine on Saturday 1st Dec. Missing the ride stat summary info which is important for my training. Appreciate some help. Thanks


Yes, starting Zwift with “Administrator Rights” helps in getting screenshots, when hitting the button on the companion app.

But the shot, just show the 3D world, regardless of an On-Screen stuff, like “Ride Reports”, “Scoreboards”, etc. This all does not go to the screenshot. That’s really a pity, since I am used to upload my ride report to Strava.

I have the same issues after the last update. I can take a screenshot but it is clean, no stat, very annoying

I emailed Zwift about this and it’s a know issue after the last update, said their working on a fix. Lots of bugs after this last update, not happy at all

i don’t know if i have the same problem but after 3dec update i can only take screenshot with the app. F10 is not working anymore.

And screenshots taken with the app are only in clean version (without gui, leaderboards and other stuff)

Hey Fabio, have you been able to update your ZC app? And when you restart Zwift are you still unable to take a screenshot with F10?

Same problem here since the 3 rd dezember, all screenshots without datas

@Michael_Sternberg @Fabio_Mussi HUD in PC/Mac screenshots are temporarily disabled due to a bug unfortunately. Sorry about the confusion!

thx for the answer. is it correct that i can t no more use f10 key vincent ?

You can use F10 but it will produce ‘clean’ screenshots without the ride data etc.

ok maybe it s a problem of my keyboard. i ve hit f10 about 10 times but no screens captured…only with the app.

Vincent, other users from my team are reporting that the F10 key is not working (but on the app it s ok)

Is it a know issue or simply it’s been disabled with recent updates ??

Still happening on Android app and windows 10 laptop. all clean snapshots. All after the last update. Nice

I got this reply from Zwift support team:

Hey Stephen,

Thanks for reaching out to us here at Zwift! It’s the busy season here and we’ve recently received a large influx of support requests from members of the community. Our team is working to get to them as quickly as possible but that’s why it’s taken a while for you to get a response. We greatly appreciate your patience while we’ve worked to get back to you!

I’m sorry you’re still experiencing issues with screenshots. The HUD (Heads-Up Display)​ was removed from screenshots in order to fix the bug we had before with corrupted screenshots​. That’s why you’re not seeing any ride data fields when you take a screenshot.

We do not have a definite timeline on when this will be fixed, and we appreciate your patience and understanding as we work to make Zwift better.

If you have any more questions or concerns, feel free to write me back! I’d be happy to further assist you!

Thank you,

Lauren M.
Member Experience Agent


What is the “fix” to something that worked perfectly for 3 years, you know what the code was a week ago, revert to that and you are golden

1 Like

What technique should I use to capture the end of ride data screens? I used to be able to capture them just fine. The recent updates have broken something. I hate to think that the only way to capture the end of ride data is to take screen shots in Windows using the Print-screen button and saving to a paint program. That seems like a giant step backward. Very tedious, too.

1 Like

Reed, I think, that is the way to do it at the moment.
Since the forums contain a lot of complaints about the broken screenshot, I guess they will fix it with the next update.
Fingers crossed.