Scosche HRMonitor NO BPM in Run App Android


(Mike Gong Fullerton Bikes) #1

Using Samsung Tab S4 with Oreo 8.1 running the latest update, Sept 28th.
Scosche HR connects fine in both Bike and Run, but HR doesn’t show up in Run, only bike. It says no signal detected.

Takes looooong time to find my Milestone footpod


(Mike Gong Fullerton Bikes) #2

What HR strap is proven to work with both run and bike an Android app. I need to get new one anyways.


(Vincent W.) #3

Hey @Mike_G in the pairing screen your heart rate monitor says “no signal detected”?
You made sure your HR monitor wasn’t paired to anything else right? And you’re connecting through BLE?

Also after finding your Milestone pod the first time, does it take a very long time to find it every time you try and pair it? Thanks for writing in!


(Mike Gong Fullerton Bikes) #4

@Vincent
It says Connected and then has “No Signal” on top. I switch to the bike module, add the HR Strap and it reads HR just fine. Switch back to the run module and no HR shows up.

I have tried this with both Scosche Rhythm+ HRM and with Jabra Elite Earbuds. Both these exhibit the same behavior.


(Mike Gong Fullerton Bikes) #5

@Vincent
IMG_20181005_053205


(Paolo Pasinelli) #6

Hey @Mike_G, Hey @Vincent

I have the same Problem with my Xiaomi A1 (Oreo 8.1) and my “CONNECT 3 in 1 heart rate monitor”.
Ride mode: HR Connected, BPM: 59
Run mode: HR Connected, BPM: no signal

Paolo


(Vincent W.) #7

Investigating with the Android dev team. Thanks for the details!

Update: @Pacio @Mike_G This is an issue the dev team is aware of and hopefully will be fixed in a coming update.


(Mike Gong Fullerton Bikes) #8

Thanks for the update Vincent.


(Jeremy Hobbs) #9

// Update to original post below (18-10-18)

Tried running on a treadmill yesterday using Zwift on iPhone X. Same experience. Milestone Pod was a little slow to be discovered by Zwift (not quite as slow on Android but certainly much slower than I’m used to with my Surface Pro 4 + ANT dongle). Connected to Wahoo Tickr heart rate strap but got the No Data message. Now…I also had the phone paired to a set of Samsung IconX bluetooth earbuds so I’m not sure whether this has something to do with the number of simultaneous bluetooth connections. This is the same config I tried to get to work previously with my Galaxy Note 9 - Tickr HRM, IconX buds, Milestone Pod. Only difference was on Galaxy Note 9 I couldn’t get the Tickr to be discovered at all.

Today just for giggles after my ride (using Surface Pro 4 + ANT dongle), I tried pairing my trainer and Tickr to Zwift running on my Galaxy Tab S4 - in addition to the BeatsX earpods that were already paired with the Tab S4. This time, both the Tickr and Trainer (Tacx Vortex) paired fine with Zwift but I got the “No Data” message for the Vortex.

Right now my working theory is that this is less of a bug than it is a function of the number and nature of devices paired.

// Original Post Below

I’ve been using Samsung Galaxy Note 9 with Zwift recently and have similar issues.

  1. Milestone footpod also takes a loooong time to pair (on the order of 2-3 minutes) and if you inadvertently touch the display or attempt to flip over to another app and back into Zwift, you have to re-pair.

  2. Wahoo Tickr HRM does not seem to want to pair in run mode. I have used it successfully in bike mode with my Tacx vortex but not in run mode. It doesn’t even find the HRM in run mode, even when I can see it in my bluetooth settings.


(Mike Gong Fullerton Bikes) #10

@jeremychobbs
Same boat as you in regards to the Milestone. I’ve spent 20 mins the last two times at the gym trying to get the pod to pair until finally I just gave up.

This is a Samsung Tab S4.


(Pinto) #11

I’m having a similar issue.

I have a jabra sport pulse headset.
When using the android app, i’ve got no HR but cadence works fine. When I’m using the companion app (on android) to connect to my mac, I get “No Signal” from the HR, cadence does not detect any steps, and after a while they both simply disconnect.
Just a note that the companion app method worked (HR+cadence) without any issues a few months ago.


(Mike Gong Fullerton Bikes) #12

Updated this morning…

Looks like RUN straps now work and New York has been added…can’t wait to try both bike and Run out tonight.


(Pinto) #13

Quick update to my yesterday post.
After the update, both HR and cadence are now working fine on the android app :slight_smile:

Still with the same problems via companion app thou, but that is not for this forum category.


(Mike Gong Fullerton Bikes) #14

Confirmed that everything now works with my Samsung Galaxy Tab S4. Heartrate strap and Milestone Footpod all work great.