Schwinn MPower Echelon2 cadence data not coming through

Hello everyone.

My setup: Schwinn MPower Echelon2, sending power data via ANT+ to the Zwift app running on Android (Samsung Note 9… and same behaviour on Note 10 too)

My problem: Power data is getting to Zwift just fine, but cadence is being estimated by Zwift or somehow not going through. Even on the pairing screen, the Power meter is showing correctly, but cadence is always showing zero. Then in game, again, power is fine, but cadence is always wrong.

My request: please help me get the correct cadence data.

Extra note: I also bought a CABLE dongle so I coild get the ANT+ data from Echelon2 into my Garmin Fenix 5x. I thought I’d try connect from CABLE via BLE to Zwift, and this works perfectly, both Power and Cadence going through properly. I’d use this setup, except that CABLE only allows one BLE connection at a time, and so I could not then connect it to my 5x which is what I bought it for.

Thank you.

Hi @Tony_Stern_TBR

Welcome to the forum.

Do you pair the trainer in the pairing screen.

Do you know it the trainer broadcast cadence?

Hi Gerrie, thank you.

  • I pair the power meter on the splash screen that appears after touching on my name on Zwift on Android
  • my meter appears as an option under cadence (but always registers 0 here)
  • it must be sending cadence data, because the CABLE dongle can pick it up on ANT+ and then rebroadcast it correctly via BLE.

The CABLE app also has a useful screen to inspect the incoming ANT+ data and the cadence is clearly visible there as well, and it is correct.

See if you see different ant+ options for power and cadense. Pick the fe-c option if available.

Hi again. It is picking up the FE-C profile and I’m selecting it. I’ve attached some photos, you can see in all cases it includes “FEC“ or FE-C” in the name of the transmitting device, and I select these.

Also:

  • thisisant says the device supports 4 profiles including FE-C (thisisant com directory mpower-echelon2-cosole)
  • The manual says that the device uses the “ANT+ Fitness Profile”
  • Interestingly on wakeup the name is transmitted as “FEC 43654” but after a minute or so the name changes to “STAR TRAC FE-C 43654”

Thanks for your interest and help.

Adding an additional diagnostic point. Running the ANT+ plugin sampler app, I can see the Echelon2 details, it is coming up as Fitness Equipment, and when I look in the Bike data category I can see both Power and Cadence data coming correctly.

So now I’m pretty sure the hardware and ANT+ protocols are working properly from the device to my phone. I’m wondering somehow whether Zwift app to ANT+ may somehow not be working right in my setup.

Tagging @will_botti if you don’t mind also taking a quick look at this when time allows.

Thanks everyone.

Hi all, just gently testing to see if there are further help or ideas.

I can literally see the cadence data getting onto my Android via ANT+ but for some reason Zwift can not read the data although it sees the sensor. On the other hand, the same data, going via the CABLE dongle after being converted to BLE works just fine in Zwift!

In sum:

  1. NOT WORKING: Echelon2 >> ANT+ >> Zwift: Power is OK, Cadence sees the device but shows 0
  2. WORKING: Echelon2 >> ANT+ >> CABLE dongle >> BLE >> Zwift: Power is OK, and Cadence is OK!!

Just needing to get (1) to work… :slight_smile: