Run Speed degrades over time


I’m having a strange problem with my Zwift run setup that I’m hard-pressed to understand.
Here’s a quick summary:

I just did a 30 minute Zwift run where the treadmill was at the same speed the entire time.
When I look at the Zwift Activity, I verified that my cadence was also relatively constant.

The run started with the Zwift speed matching the treadmill speed (I was at 5.5 mph).
However, as the run went on, Zwift was showing me progressively slower and slower.
By the end of the run the treadmill was still 5.5 but the Zwift speed was listed as 5.0 mph (10% off).

I tried to solve an obvious problems:

I was having this problem with the Zwift Pod, so I bought a Polar Stride thinking that it would be more accurate. This latest run was with the Polar and still exhibits the problem.

I calibrated my pod just before I ran, and I assume it worked because the start of the run was pretty accurate.

I downloaded my Zwift into Zwiftalyze to make sure that there were no errors or problems (nothing).

This happens on multiple devices, so shouldn’t be a hardware or calibration problem.

Brand new iPhone 11 running zwift, so assume this is not a capacity problem.

Can anyone think of any other variable that would lead to this type of degradation?