Run pace zones not aligned between TrainingPeaks and Zwift


This week, the transfer of run workouts from Training Peaks (TP) to Zwift are not 1-to-1 (workout on Treadmill).
E.g. in TP I have set the % of threshold to 4:06 min/km for intervals. Then, when I open the workout in Zwift the pace is 3:40 min/km (for the same intervals).
Why is it like that?
Why suddenly doesn’t it work?

BR Magnus

Hi Magnus, welcome to the forums. Zwift and TrainingPeaks don’t sync up the paces and thresholds so any time changes are made to those values on one platform it needs to be updated on the other as well to keep the workout intensities matching up correctly.

Thanks for the reply.

Though, I am thoughtful… but maybe the zones have changed automatically in TP, because I have not adjusted this manually?.

Anyway, how do you adjust this in Zwift so you have the same settings as in TrainingPeaks?
As far as I know, you adjust times at different distances in Zwift, but in TrainingPeaks you adjust after eg 10 km or threshold value.

I have done it this way but unfortunately do not get it correct anyway.

What am I missing?
Do I overlooking something?
Thanks in advance

I took another look at the zones in TrainingPeaks and I’m not entirely certain how those zones match up to the Zwift zones since we use common running distances for our zones and TP uses a percentage of the threshold pace for their zones. One thing I can see for sure though is that when running workouts that are built in TP using threshold percentage, they are converted to Zwift using 10km pace percentage so as long as your TrainingPeaks threshold pace matches your Zwift 10km pace then the final paces for the workouts should work out to be the same.

The strange thing is that it has worked earlier, i.e. TP workouts has worked as it should according to set speed/pace zones.
I have now set the same “value” according to 10k but still it doesn’t match. The speed/pace is to high.

Any zwift updates that has “affected” sync between TP and Zwift?


I did some checks for speed/pace between TP and Zwift, see screen dump.
100% of threshold is equal between TP and Zwift.
BUT, when percentage of threshold is used for apply to difference run speed/pace zones, for instance 93% and 108%, it deviates “heavily”!

As mentioned earlier, no problem in the past but this week I have this problem.

1 Like

Hi, I just looked it up for my workout for today. Everything normal there.

If you select the TP workout in Zwift and hover over an Intervall block, does it say x % of threshold?

Edit: It did not help to remove and add.

Yes, it says percentage of threshold.

I have done more investigation, and when I create a new workout in TP it works.
The problem workouts, are the ones that I have added earlier from Phil Mosley Ironman plan. These ones have an issue. I don’t know why but I will remove and add the plan again to see if this helps.
Thanks again for your reply, really appreciated!

I have figured something out but where the issues is, it beats me…

So, when I build an workout with different blocks, as “Two Steps Repeats”, the speed/pace is not accordingly in Zwift. BUT, when I build it with “Active” blocks, is accordingly!

I will to the treadmill workouts manually with “active” block only then… it works but takes more time.

Thanks for that extra info about block types, it really helped me look into this better. I made some test workouts on TrainingPeaks and exported them to look at the ZWO commands to see exactly what’s going on between the two block types and it looks like when the “Two Step Repeats” blocks are getting converted they aren’t having the pace designated which means that those blocks are using the default 1 mi pace when Zwift reads them. Since the conversion to ZWO is handled by TrainingPeaks this is something that needs to be adjusted on their end.

1 Like

I am still experiencing this issue and was wondering if Zwift has figured out a fix as I use Structured Workouts with multi steps frequently. In fact my workout this morning had a problem. I would sincerely like a fix for this issue

I am aware its an old thread, but I started having this very same issue in spring and had to do the running intervals having the accurate paces written up or memorized.

I thought it could been some wrong data in the plan but this season I reapplied the training plan and even the 1st workouts are showing this behaviour (when last year they were fine) so the issue is not in the plans but something that was changed in spring on any of sides that made the pace transfers started to fail.

Any workaround or fix would be appreciated, as it is now is pretty much equivalent to not having any pacing showing since you have to read up beforehand the real ones and have to manually check them

If the issue is still happening then Training Peaks hasn’t fixed it yet. The issue is that TP needs to add the Run Pace code to each threshold target and they aren’t doing that. In theory Zwift could write a fix for it, but that would be a considerably higher amount of coding than just adding one text command from TPs end of things and would not only take up server power but potentially alter legitimate workouts that were designed to use different Run Paces

Exact same thing was happening to me. I played around with my paces in Zwift and was able to change the interval paces to match what I made in TP by adjusting my 1 Mile Pace in Zwift. Kind of annoying but now when my run workouts in TP sync to Zwift, it shows the proper paces for my intervals.

1 Like

Where can you adjust your 1 mile pace in zwift?

Can’t find it anywhere

@Armand_Pinel_F2C did you set 1 mile pace equal to 10k pace in Zwift?
… I assume that TP = Zwift is “synced” via 10k pace?

Thanks for sharing this - I’m also having the same which led to my zones being double what they should be - no wonder the sprint intervals were killing me!

I’m struggling to find where to set the pace zones in Zwift … any pointers?

I had the same issue and modified my “times” in zwift. A bit annoying as I modified them till I got the right pace in my workouts.
But I have another issue: distance of the workouts are not matching. Warm up and cool down are ok but for the “hard workout” Zwift indicates (for example) 1600 m instead of 1500… Have you faced the same issue?
Many thanks for your help :slight_smile: