Quarq Dzero bluetooth bug


(Douglas Young) #1

I reported this bug around 6 months ago and still no word on a fix!

When using the Quarq Dzero power meter as the power source when I stopped pedaling the watts would stay at whatever they were before I stopped pedaling. I noticed this on a downhill when I jumped to 500w to get my speed up and then coasted down the hill at 0 rpm. The game thought I was doing 500w the whole way!! This is 100% repeatable as I later tested.

If i let my Kickr control the power then there is no problem. 

What the hell is going on?

In the Zwift riders group on facebook I was told " we’re actually in the process of figuring out which BLE devices are still doing this, as we’ve already addressed the issue on a number of speed sensors and some power meters. Can you please open a support ticket for us, so we can get your logs? We’ll get your device added to our database to be addressed as well. Thanks!"

I took a break from Zwift for a while and low and behold 6 months later the bug is still there. The original ticket I created 6 months ago is still open so presumably it is still being investigated? what is going on? I replied on my ticket almost 2 weeks ago and haven’t received any kind of reply. Don’t really like being totally ignored when this is a service i’m paying for!


(Robert Hausmann) #2

Same problem with Quarq Dzero Power on Zwift (with iOS and MacBook Pro)!  Any updates on this?  It also does similar weirdness with the Quarq Dzero cadence.  

Any updates, Zwift?  I’m sure we are not the only ones…

Thanks! 


(Douglas Young) #3

It’s still “being looked into”. Apparently they didnt even have a dzero in their test pool or something. Seems a bit strange seeing as quarq are one of the biggest players in the PM world. It has been super difficult to even get a response from zwift support. Just flat out ignore me most of the time.


(Douglas Young) #4

Last response I got was from someone on Facebook that worked for zwift. Saying she would look into it and get back to me. That was weeks ago… Last response to my support ticket was months ago. No idea what’s going on but it’s been 8 months and counting since I reported this.


(Robert Hausmann) #5

Thanks @Douglas.  It is nice to know I’m not crazy as I tear my hair out trying to find an answer.  

Even if Z could suggest a workaround?!?  Just shed some light on the situation, guys.  If this is low priority --let us know that too.  Thanks!    

 

   


(Marcel Lopez) #6

Did you try to use the Zwift Mobile Link app to bridge your Quarq power meter? I used it and it actually was able to give me a reliable cadence reading. When connecting it directly to my Mac over BT it starts but then it just drops to 0 after maybe 40 RPM.


(Marcel Lopez) #7

Just confirmed that this is the way to get cadence from a Quarq DZero PM. It worked flawlesly.


(Robert Hausmann) #8

Thanks so much! This is great news that it works in this way. It is still at work around… But one I think I can work with. Appreciate knowing it worked well for you… I’ll give it a try and report back.

Appreciate to help!

Robert


(Douglas Young) #9

The latest update appears to have fixed this bug. Atleast from the short test I did today. Only took them 8 months! yay.


(Steven Baker) #10

just joined today. pile of crap. still not sorted this issue. i shall be cancelling my subscription immediately 


(Victor Charlie) #11

Is this indeed why I am unable to connect my Quarq Dzero with Zwift on my (bluetooth only) Apple TV? Seems like a bug indeed. The Apple TV does indeed see the Quarq Dzero power meter, but seems to be unable to connect to it. Zwift ATV does seamlessly connect to my Elite Direto though…


(Conor Buckley) #12

I am a having the same problem with my Quarq Dzero on Zwift using my MacBook Pro but only on an intermittent basis. Some days it works fine and then other days it’s hit and miss (more miss than hit). It’s very frustrating.


(Marcel Lopez) #13

Don’t connect the DZero directly to the MacBook. I had the same issue when trying it this way. What fixed it for me, both for Mac and Windows, is using the Zwift Mobile Link app.


(James Madelaine) #14

What about if you’re using Zwift iOS? You can’t use the mobile app at the same time as Zwift, so cannot use the mobile app as a bridge.


(Lee Prouty | Velocause) #15

My Quarq Dezero reads like 54 watts when im off the bike on apple tv 4k, I bridge through the phone app on my iphone X, this is annoying lol


(Brian Clark) #16

Same bug. Quarq DZero. I have to backpedal a couple of times to get back to 0 if I want to stop pedaling. Surely you guys have a Quarq test unit. If it helps, I’m connecting to a notebook via Bluetooth using an iPad as the bluetooth relay. Of course, this doesn’t happen out in real world conditions, and the Elemnt Bolt reports 0 when expected, without the backpedal reset.