Pushed out of group/draft

Hi. I am a Beta user of Zwift Play and it has been fairly positive. I love riding with pacer bots and now I can switch to a faster group as I warm up. However, my avatar keeps moving out of the peloton to the right side of the riding path. I use the left controller to move back to the middle of the group. Then we enter a new segment and my avatar moves back to the far right. It is not fatal…just annoying.

Is it possible to disable the steering to just ride with the bots?


Because the Play controllers pair as a steering device, I do not believe there is a way to remove steering. I’ve heard of this issue and I’ll try to find the thread where I saw it.

Do you happen to use a Kickr Bike?

Same here yesterday by a Race, breaks out of the peloton to the right side too, 8 or 9 times 45min-race.

fw 1.1.0
Samsung Galaxy tab s7

i think this is a known bug hopefully being worked on i had the exact same thing on a sprint was pushed ride into no draft despite hold the left paddle to if did then click in a second or two later and swung me over but lost the spring by that time.

1 Like

I do not have a Kickr bike. I am using a normal Wahoo Kickr (4.0 I think)

Interestingly I have heard from folks with Kickr bikes using steering (without Play controllers) having the same problem.

I had the same issue, except my avatar was far right one day, the next day left. Following the firmware update, we’re back to center - hopefully it will stay there.

I wonder if this is a general steering bug. I have a kickr bike and it does it, now have play controllers and does it.

I think as steering wasn’t well adopted so it was mainly kickr bike riders complaining.

Now that it’s more widely adopted everyone is experiencing the bug.

Hopefully now Zwift will fix it :smile:

1 Like

In a group ride, keep getting pushed out of the group to the right-hand side of the road. Seen other complaints about this, but this is new to me having just installed the new Zwift controllers. I am on a Kickr bike, which has existing steering buttons. Continually having to veer back into the draft using controllers, but mostly losing draft.
Should I just turn off all steering in a group ride and trust in Zwift?

I also get pushed out to the right as well at times. Seems better after the 1.1 firmware update. Are you on version 1.1?

Yes. Upgrading firmware now. Thanks for the tip.

i think that is a known issue. i certainly have had it with zwift play controllers.

There is some work being done with pack dynamics to rollout soon so hopefully that will be a fix but @DavidP would know best.

The kickr bike has long had a steering related bug.
Prior to steering being on in most races when you entered a pen paired via bluetooth and had “steering disabled” displayed you would frequently get kicked to the side of TT lines and blobs.
(The fix was to swap to ANT+ and suddenly you got the default zwift steering algorithm back)

There seems to be a possibly related bug with bluetooth and the kickr bike too.
In the scenario above, even though you were paired on ANT having previously been on BT you could still steer and use hood buttons for powerups despite having “unpaired”.

That persists to today. I have a kickr bike and also got the play controllers. initally my bike paired as the steering system and I had to choose the play controllers. I was then warned that the kickr bike was “incompatible with them” and had to uncheck it as a steering device.

However when in game both the play controllers AND bike were able to steer and the hood buttons also worked on the bike.

With either steering devices enabled I too get shot out of the sides of packs every once in a while, but unlike the non-steering race days at least I can steer back to the blob. Inconvenient but not the huge disadvantage it used to be doing an entire TTT off the the side of the draft.

Yes, these issues with steering should be fixed with the release coming around mid July.


Windows PC / Windows 10
KickrBike v1 (latest firmware)
Bluetooth power + controllable from KB.
Steering from KB

These could be two related bugs. I’d be interested to understand if this is a known issue, or occurring for other riders.

When riding around the avatar will automatically steer hard to the left or right (seems to be more commonly right). This is more than just adjusting around the pack, it will push you to the far lane. You can generally steer back into the pack but at times the game will also lock out steering for a time.

I have validated that it is not the kickr bike causing the issue, low power supply to the bike, and my internet connection today never dropped below 500 down 250 up, with a consistent ping below 12.

Resetting the bike by power cycling it while connected to zwift does not fix the issue when it occurs. Unpair and pairing again did not solve the issue once it is triggered.

This has recently occurred in Watopia, and London. It has only happened to me in London since the last patch. It has not occurred outside of races.

[quote=“Matt [+R], post:16, topic:608729, username:Matt_Wheeler”]
I have validated that it is not the kickr bike causing the issue,

It’s a general steering bug, not kickr bike. Happens with the Tacx bike (now that it has steering) as well as the Zwift play controllers.

1 Like

That’s good to hear confirmation of… I nearly went through a replacement cycle with Wahoo while on with their support because it was playing out like an electronics issue.

Please confirm - this will not be addressed until the July update? So we just let the Zwift Play controllers sit unused until then?

The Play controllers aren’t just for steering. You can still use the other buttons even if this steering problem happens a lot for you.