Privacy settings greyed out in Zwift Companion

Has there been a recent change in Privacy settings? I’m running current (3.11.0 - Android) version of Companion and just now I noticed I had to manually approve a follower. I never had to do that before - I want to keep my profile as open as possible.

Upon further investigation when I go to Settings > Privacy the top 2 sliders are turned ON and greyed out (pic related).

This means I’m stuck manually approving follow requests and only followers can DM me.

Help.

Can you toggle the sliders even if they are gray?

Mine turn blue when I toggle them on.

@V_itek_Holubovsky
The date of birth in your current profile settings means you’re one month old. Please correct it here: https://my.zwift.com/profile/edit

Profiles for accounts that belong to adults will behave the way you want.

3 Likes

Is there another way without having to input my year of birth? I don’t recall ever putting this information in, yet Companion worked flawlessly. I don’t necessarily want everyone know how old I am. Isn’t there another way?

You can probably put any date that will indicate you are an adult, 1998 should do it.

Just remember if you do Age related races you need to put the correct date.

The date of birth didn’t have an effect with previous version. It does now because we’re moving toward compliance with international child protection laws for websites and game platforms.

1 Like

Okay. That makes sense. Thank you.

I have a related issue. I am trying to update the privacy on my child’s account (this account actually) but those settings are also grayed out for me. The slider is toggled to the left position (round bit is on the left side) which I believe means they are not “ON.” However, for privacy of my child’s account, I want them to be ON.

1 Like

@Levi_Bergman
Do you mean in the Zwift Companion app? Does your child’s account look like this in ZC?

This is what it will look like when the privacy settings are locked to ON. For kids under 16, the setting should be stuck to ON, so it will be greyed out.

Yes, in the companion app.

Here is the screen shot from my child’s account. They appear to be OFF which is not what is recommended for child account.

@Levi_Bergman
Please verify you’re on the latest version of the Zwift Companion app. A new one went out yesterday, and that should resolve it. If it does not, please let me know.

1 Like

Android
App version is 3.12.0 (1017)
Server Version: 1.184.8

No update appears to be available when I checked Google Play just now. ZC does indicate that it was updated yesterday. I just re-confirmed privacy settings are still as shown as my screenshot above.

@Levi_Bergman
We changed a setting on this end. Please log out / in of Zwift Companion and check on your end?

50% fixed. :slight_smile:

@Levi_Bergman

Was given an update: the Private Messaging is locked to OFF for child accounts. Children don’t get to use the PM feature at all. This is the most assured way to keep questionable adults from messaging kids. Hope this makes sense?

Yes, it makes sense that private messaging should not be available at all for child accounts. Thank you for clarifying and I appreciate your help with this.

One final comment though. The way the Private Messaging option is currently written, it seems to imply that if the selection is “OFF” you will be able to receive direct messages from everyone, not just those that you follow. Sounds like there is different logic applied under the covers for a child account vs. adult account for Private Messaging as a whole though. To better communicate this to the user, perhaps a higher level selection is needed to toggle Private Messaging capability on/off, with the current option nested below that and only selectable if PM is “ON”? Adult accounts would then be able to turn PM fully off if desired, the UI would continue to be the same experience for child and adult accounts, and the adult user would have better control of PM preferences.

2 Likes