OK Button in Pairing Screen is Same Location as RIDE button in Home Screen

Update Request: in the device pairing screen, move the OK button to be left justified with the left edge of the device selection panes, and below the Heart Rate device pairing selection pane.

In the Paired Devices screen (MacOS), the OK button is in the same location as the RIDE button in the “World Choice” / “Ride Type” / Device Status screen.

If one clicks the OK button too quickly—ie double click—one is launched directly into the game environment, without being able to set a world/course/workout.

This is poor UI design: frustrating to users who need to select a world, route, or workout, after pairing devices, before launching into the game.

I think this is an interesting observation, and may explain why in other threads I have seen comments about being dumped directly into a world and course, instead of being able to choose. Personally I have never experienced this (Apple TV), but I can certainly see how it could happen, especially since a ‘double click’ is such a common habit.

1 Like

I use windows so it may be different, but once I have paired all my devices I don’t have to press OK, a countdown will start and it will go to the Home screen.

I agree with @Jeffrey_Bauer, this might explain the other user comments in other threads. :thinking:

yeah - i have done this too - it is really annoying

this! i have made this stupid mistake so many times!

It seem like a small delay between the two windows will do the trick, just enough so that the second click does not impact the Ride button.

nothing in Zwift requires a double click, just don’t double click and problem solved.

1 Like

in my experience, it’s not always clear if your first click worked or not. you click, wait a few seconds, nothing happens, so you click again, and then miraculously both clicks register in quick succession.

1 Like

There is another awkward possible overlap of buttons when returning from the garage to go back to your riding screen and having to pick the back button.
I have accidentally hit the end ride button instead and there is no option to go back from that. :frowning_face:
I have only done this once because I messed up my ride big time so learnt the hard way. :cry:
Has anyone else made that mistake or am I the only fool…

The back button top left will take you back.

1 Like

Cheers Gerrie,
in my disappointment I didn’t notice that.
That makes me feel even more stupid than I did in the first place.
Thanks for making me feel even worse. LOL :grinning:

1 Like

LOL that was not my aim… to your credit that back button is very small.

@_Troy I assume you use ATV, do your paring screen also do the count down once you paired all your sensors like on windows. (as I mentioned in my first post)

I thought, a UI redesign is due this month anyway?

I don’t know about this month but I heard Zoon.

It happens to me when my computer lags slightly, so it isn’t a double click just clicking again because it doesn’t look like the computer registered the first one.

It is probably a hardware issue with slower PCs but moving the buttons would solve it - for me at least!