Not understanding FTP Test

I have done FTP tests on other sites and normally end up at 220-230.  When I did the “long” FTP the first day released, it crashed and didn’t provide a number.  Today, I had just a little time so I thought I would try to short FTP.  I use a Wahoo KICKR with ERG mode and all the warm up stages change the resistance to get the desired power level without my changing cadence.  When it got to the 20 minutes of the FTP test, though, i just kept cruising along at 95 RPM, 110 on the HR, and doing less than 2w/kg - in other words, hardly more than taking a walk in the park.  Half way through, it said I should try to add 10 watts if I felt it was too easy.  How??  It was going to end with an FTP of ~150 and my hardly even feeling like I was riding.  What am I missing about how to conduct the FTP on Zwift?

I have not done an FTP test on Zwift but from what I understand it turns off ERG mode for the test portion and then it is up to you to change gears and do a MAX 20 min. interval.

If you were max’d out with gearing and still only leisurely riding along, then it seems the FTP test is “broken” from my perspective.

Now, I have been able to use the Wahoo App to control resistance even when Zwift is configured to use my KICKR as a controllable trainer. This always seemed to work when I’m "Just Ride"ing. I’ve never tried this during a workout when Zwift is in ERG mode. Perhaps it would still work during a workout as long as Zwift was out of ERG mode such as during the FTP test portion.


Thanks.  I tried two means of increasing the power when I was in the FTP portion.  One was much faster cadence when I took it up to 120 RPM.  The pose went up for a little while and then started dropping, like Zwift was reverting to its desired power.  The second thing was changing gears and it seemed to have the same effect - increase power for a short duration and then back to the 150-160 watts range.  If one of those is the means that we’re supposed to use, it doesn’t seem to work very well.

yea, sounds like the FTP test is “broken”. 

I’ve heard many others reporting a less than desirable experience.

maybe try using the Wahoo App at the same time? If you don’t want to, I understand, this should just work in Zwift. Though in all fairness, workout mode is still in beta technically. I always perform my FTP tests outside on the same course, so the FTP workouts in Zwift are not much interest to me.


I just completed the short ftp test today on my kickr (just got it yesterday). Everything was rolling smooth. During the warm up and initial power zones the kickr controlled everything smashingly. Once the 20 min test started it started spinning out. I went to the hardest gears and into 120rpms and couldn’t get it above 150w. I opened the wahoo utility app and went to change the resistance and suddenly it was on full hard, spiked my wattage, had to hit the minus button and shift to easier gears, after a minute or more I got settled into a good pace. At that point it was all good for the rest of the test. I put in a ticket for some help. Hopefully they can fix it or let us know how to.


This exact same thing happened to me today…a year later.  Did any of you figure out what’s happening or how to fix it?

same happened to me too

Identical thing just happened to me.  Kickr trainer.  ERG mode, short FTP test.

Its February 2017 now.  This is an 18-month old bug.

Maybe its time to fix this.

My solution has been to use Trainer Road for my FTP tests.

EGR dont turn off on my Kickr. What a bummer after all that warmup.

Good afternoon H�P SMRSN W/KG.

Can you give us more information on what happens when you get to the 20 min FTP test section.


My understanding of FTP tests and ERG mode is that in the warmup section the trainer will set it self to the required wattage and when you get to the 20 minute section ERG will turn off and you have to manually adjust the resistance from the trainer app or trainer buttons and your gears.

ERG cant control the resistance during the test since it does not know what power you are aiming for.


I hope this make sense. 






It lost all resistance (in a climb) and I could only push about 178W even if on the heaviest gear. It was clearly limited as if in EGR mode where you can pedal harder than the wattage shows, but locks in the watts that are displayed.

I have the latest Kickr and no option to adjust resistance or turn off EGR in Zwift in a session like this.

I’m having the same issue. Am I supposed to manually adjust my resistance on wahoo app or turn off EGR mode for FTP test?

I’m having the same issue. Am I supposed to manually adjust my resistance on wahoo app or turn off EGR mode for FTP test?

I am also having this issue on both FTP and FTP (Shorter)

Hi brand new kickr did the short ftp all ok resistance controlled fine in warmup but as soon as the 20 min test section comes in I can’t raise more than 110W without running out of gears no resistance?  Is there a fix for this do I need to have the Wahoo utility running too?

I just tried the short FTP test as well, have the Kickr with the latest firmware, and had the same experience. It does not turn of ERG mode when you get into the 20 min FTP test part. Just stays in ERG with teh last used Watt . I tried to controll it with the wahoo app, but no luck.


And regardelss, the FTP test does not seem to function properly. It says ERG mode off in Swift app, but it has not turned it off on the Kickr

Hi just an update on this issue I found my problem was because I had the Kickr trainer connected to other apps via bluetooth.

I have since run successful FTP ensuring the smart trainer is ONLY connected to Zwift nothing else.

Same issue as above. The watts were fine during the warm ups but when the 20 minute session started I would just spin at 120rpm regardless of gear and get a max of about 200 watts. Great cadence session but couldn’t really lay down any real power. Computrainer…