Not syncing to strava 9/13/2023

I finish a ride is zwift, I click upload when it asks, it seems to do everything fine, no errors. Check strava it’s not there. I see it in my zwift feed, but not strava. Happened the last 2 rides. I’ve had it connecting to Strava with no issue for a long time. Confirmed it still has the connection listed on my account connections page. Any thoughts?

I’m following this because the same is happening to me for the last 5 rides…

Have you already tried removing the connection and adding it back?

I hadn’t, tried that didn’t seem to do anything (other people with same issue should give it a shot) A bunch of screwing around later I discovered the machine has some issue with wifi and was picking up the 2.4ghz version of the network (which should be the stronger signal) and was getting almost no connectivity and the upload was timing out. I forced it to the 5gz and things all started working as the connectivity picked up to the 50Mbs range to the internet. Machine is only used for zwift so nothing else would have flagged the weird networking speed thing.

1 Like