No road surface! Riding on water!

I’ve been getting some very strange graphics for a couple of weeks. Typically this happens in Watopia around the volcano. Missing road surface, riding in the air, riding on water, constantly being followed by what appears to be the shadow of a tree walking in the air (seriously - stuff of nightmares). Screenshots below. Is anyone else getting this?

What system do you use for zwift?

Can you put your log file in zwiftalizer.com and look at network dropouts and your frame rates.

1 Like

Better put a picture…

I tried to add images but the system won’t allow me to. I get the message “Sorry, you can’t embed media items in a post”. I see others have added images so I’m guessing this is a ‘trust level’ thing preventing me from posting images until I’ve reached some sort of threshold on the forum. But there’s no explanation or help on the forum, so I’m just guessing.

Here’s for another bug then… :slight_smile:

Hi Gerrie

I tried to reply with images but the system won’t let me attach anything. I get the error “Sorry, you can’t embed media items in a post”. I also get this when I reply from my mail account.

FPS and network connections look ok on Zwiftaliser. I typically get a couple of network connections at the start, and 60 FPS throughout ride. Frame rate does drop occasionally but this has always been the case for me and before the last two weeks I did not get any of these weird graphic issues. I get the impression somethings not right with the platform. By the way I get no tearing, stuttering or other artefacts. I’m running fairly strong hardware and the only thing Zwift can suggest is I try lower the resolution in the settings (for me this is a total BS reply. The issues clearly have nothing to do with my hardware, the proof of this being that i) lowering resolution does not fix it and ii) these issues do not occur in other worlds).

Also worth noting that the following error is now regularly seen in my log files

ERROR: Cannot create new MeshHandle: MAX_MESH_RESOURCES [4096] reached!

This shows up 10’s of 10,000’s of times in current log files for rides of typically 1 hour. My log files used to have a file size of a few thousand KB. They are now more than a few 100,000 KD (yesterday’s file was 238,000 KB and this is all due to the inclusion of this error message. I stripped the message out with find/replace and the file size returned to something more normal.

Nothing on google, but looks like a graphics related error.

This error does not appear in older log files.

System info as follows;

Windows 10 Pro 64-bit (10.0, Build 19041) (19041.vb_release.191206-1406)
Gigabyte B365M DS3H motherboard
i5-9400F CPU @ 2.90GHz (6 CPUs), ~2.9GHz
16GB DDR4 2666 RAM
DirectX 12
NVIDIA GeForce GTX 1650 SUPER

Seems related to Openmesh, a C++ library. I suspect all these bugs are related tbh.

Edit: if it’s been happening a few weeks then that’s different. Have you tried a full reinstall?

Thanks Dave. It has only been happening for the last few weeks (since zwift updated to fix some graphics issues!). I was thinking to full reinstall. Will give this a go and report back.

Make sure you follow the full process: https://support.zwift.com/en_us/re-installing-zwift-BymCF82TH

1 Like

Perhaps related, perhaps not:

I recently free rode Richmond UCI reverse (manually) and had a lot of short, sub-second flashes where the road surface was replaced by all white or all blue, right from the start of the ride, which has never happened before.

2012 MBP Mojave 10.14.6 8GB NVIDIVA GeForce GT 650M 1GB / Intel HD Graphics 4000 1536 MB with no history of previous issues.

That’s Dave, that’s very helpful.

1 Like

Dave/Gerrie, just a quick update. Clean installed Zwift per the instructions. All problems solved. Thanks for the help.

Frank

2 Likes

Glad it worked for you but it was mostly @DaveH he is a PC graphics master. :sunglasses:

All help appreciated. The main lesson for me is to look out for log file size increases, and errors in the log file such as “ERROR: Cannot create new MeshHandle: MAX_MESH_RESOURCES [4096] reached!”
When these happen, it’s time for a clean install. I still suspect the origin of this was a recent update, but matters not now.

1 Like

Certainly could have been due to a bad patch, if something was interrupted or didn’t install correctly. But yeah keep an eye on those log files, I’ve seen it mentioned before on here that they can get massive when there’s a recurring error happening.

Glad it seems sorted anyway. :+1:

1 Like